Closed Bug 371054 Opened 13 years ago Closed 11 years ago

Hiding/unhiding table rows puts table cells out of alignment

Categories

(Core :: Layout, defect)

defect
Not set

Tracking

()

RESOLVED FIXED

People

(Reporter: tmcgee, Assigned: bzbarsky)

References

Details

(Keywords: testcase)

Attachments

(4 files, 1 obsolete file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: Mozilla/5.0(Windows;U;WindowsNT 5.1;en-US;rv:1.8.1.1) Gecko/20061204 Firefox/2.0.0.1

Building a collapsible table, starting out with all the rows except a header hidden. Opening up the table, the columns don't line up or line up randomly. 

Reproducible: Sometimes

Steps to Reproduce:
1. Try the attached HTML
2. Click on the "+" sign
3. Click on the "-" sign
4. Repeat; Reload
Actual Results:  
See attachment. Columns, including borders, don't line up vertically.

Expected Results:  
A normal table grid display
Attachments to come -- file upload is blocked from my current location
Version: unspecified → 2.0 Branch
Attached file HTML/CSS/NJ (obsolete) —
Attached image As displayed in IE
Attachment #255815 - Attachment is obsolete: true
Component: General → Layout
Product: Firefox → Core
QA Contact: general → layout
Version: 2.0 Branch → 1.8 Branch
Updated to 2.0.0.2 over the weekend, but the issue persists. 
Attached file small testcase
If it's not a dupe of bug 148810 it at least depends on it.
Status: UNCONFIRMED → NEW
Depends on: 148810
Ever confirmed: true
Keywords: testcase
OS: Windows XP → All
Hardware: x86 → All
Whiteboard: DUPEME?
Version: 1.8 Branch → Trunk
Fixed by checkin for bug 148810.  Added tests.
Assignee: nobody → bzbarsky
Status: NEW → RESOLVED
Closed: 11 years ago
Flags: in-testsuite+
Resolution: --- → FIXED
Whiteboard: DUPEME?
You need to log in before you can comment on or make changes to this bug.