[suiterunner] BACK and FORWARD do not work

RESOLVED DUPLICATE of bug 350221

Status

RESOLVED DUPLICATE of bug 350221
12 years ago
12 years ago

People

(Reporter: georg, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a3pre) Gecko/20070220 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a3pre) Gecko/20070220 SeaMonkey/1.5a

With the SuiteRunner-Build following happens:

BACK and (probably FORWARD) do not work, the drop down menu in the location bar seems to work, but the history in the sidebar seems to record only bugzilla pages.

BACK button is mostly disabled, but even if enabled nothing happens.

Trying javascript:alert(history.back()) in the location bar causes following exception. Nothing else happens.

Error: uncaught exception: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIDOMHistory.back]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: javascript:alert(history.back()) :: <TOP_LEVEL> :: line 1"  data: no]

Click on the BACK button does not throw an exception.

Oh, as I just see, in bugzilla the BACK and FORWARD works. Does it work only with https: but not with http: and not with about:

Reproducible: Always

Steps to Reproduce:
1.
2.
3.
(Reporter)

Comment 1

12 years ago
With SuiteRunner Build identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.9a3pre) Gecko/2007022111 SeaMonkey/1.5a from http://ftp.mozilla.org/pub/mozilla.org/seamonkey/tinderbox-builds/phlox-trunk/ (same source as above) the same problem occures.

But I must precise the description of the problem. It has nothing to do with the protocol, but occures in the initial browser window in the first tab only. If I create more tabs it doe not occure in the second and later tabs. 

Comment 2

12 years ago
SuiteRunner Build identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a3pre) Gecko/2007031419 SeaMonkey/1.5a - the same problem occured.

For button Back Error Console view:
Error: [Exception... "Component returned failure code: 0x80004005 (NS_ERROR_FAILURE) [nsIWebNavigation.canGoBack]"  nsresult: "0x80004005 (NS_ERROR_FAILURE)"  location: "JS frame :: chrome://navigator/content/nsBrowserStatusHandler.js :: anonymous :: line 319"  data: no]

Updated

12 years ago
Summary: BACK and FORWARD do not work → [suiterunner] BACK and FORWARD do not work

Comment 3

12 years ago
This will work when we have tabbrowser fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 350221
You need to log in before you can comment on or make changes to this bug.