[NS] unable to view Forms & Passwords panel in prefs, parsing error

VERIFIED FIXED in M16

Status

SeaMonkey
Preferences
P3
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Ben Goodger (use ben at mozilla dot org for email))

Tracking

({regression})

Trunk
regression

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+][6/1])

(Reporter)

Description

18 years ago
found this using today's opt comm bit, 2000.04.25.09.

1. open Preferences dialog.
2. double-click Advanced category to list its children (bug 37090).
3. click the Forms and Passwords category.

result: the panel loads with a parsing error displayed, "XML Parsing Error:
undefined entity. Line number 69, column 24: <title><text
value="&walletHeader.label;"/></title>
(Reporter)

Updated

18 years ago
Keywords: regression

Comment 1

18 years ago
win32 build 2000042508 on nt4sp3 just goes off into limbo when the 'View Saved 
Signons' clicked.  (i didn't get the missing entity error.)

Comment 2

18 years ago
This is another instance of a bug introduced because we are duplicating dtd file 
information in the mozilla tree and the ns tree.  I've already fielded and fixed 
numerous regressions due to this.  I'd like to again make a strong appeal that 
we remove the unnecessary redundancy.

This particular bug was introduced by ben yesterday when he changed the names of 
the symbols in the mozilla tree's version of pref-wallet.dtd but didn't make the 
corresponding changes to the ns tree's version.  In particular, he changed the 
symbol named walletHeader to be walletHeader.label.

I'll fix this as soon as the tree opens today by checking the current mozilla 
version of this file into the ns tree.  If this is the wrong thing to do, please 
notify me immediately.
Status: NEW → ASSIGNED

Comment 3

18 years ago
jonrekai's problem is different and not related to this bug at all.  I believe 
what (s)he is reporting is a dup of bug 37073.

Comment 4

18 years ago
Fix checked in as described above.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 5

18 years ago
still a problem, commercial bits only, 2000.05.09.08. reopening. parsing error
now reads "Line number 91, column 24."
Status: RESOLVED → REOPENED
Keywords: nsonly
Resolution: FIXED → ---

Comment 6

18 years ago
Ben, how can this be!  This is the duplicated dtd file problem again.  But I was 
aware of it before making a change yesterday, and I went to add the identical 
change to the netscape version.  When I did so, the cvs system said something to 
the effect that the netscape versions had been removed.  So that led me to 
believe that the duplicated file problem had finally been fixed and we no 
longer had to keep making the changes in both places.  But it appears from 
Sarah's report today that I was wrong.  What is the situation with the 
duplicated files -- pref-wallet.dtd in particular?
Status: REOPENED → ASSIGNED
Target Milestone: --- → M16

Updated

18 years ago
Keywords: nsbeta2

Comment 7

18 years ago
[nsbeta2+][6/1]
Whiteboard: [nsbeta2+][6/1]

Comment 8

18 years ago
Looks like the removal of the duplicate dtd files missed some necessary changes 
to makefiles.  Ben just made these changes and checked them in so that should 
fix the problem.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

18 years ago
reopening. still a problem. unless the files haven't been checked in yet?
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 10

18 years ago
Reassinging to Ben.  Looks like his change to remove the duplicate dtd files is 
still incorrect.

Comment 11

18 years ago
Now I'm really reassigning to Ben.  (I thought I did so this afternoon but 
apparently I didn't.)
Assignee: morse → ben
Status: REOPENED → NEW
Summary: unable to view Forms & Passwords panel in prefs, parsing error → [NS] unable to view Forms & Passwords panel in prefs, parsing error

Comment 12

18 years ago
OK, I see the problem.  Not only was the pref-wallet.dtd file duplicated between 
the mozilla tree and the ns tree, but it actually appeared twice in the ns tree, 
making a total of three independent copies of this file.  No wonder this has 
been so devastating!

So first Ben did the right thing by removing it from 
ns/xpfe/components/prefwindow/resources/locale/en-US.  But now we were being bit 
by the second copy in the ns tree, namely at 
ns/AIMGlue/resources/locale/en-US/pref.

As soon as the tree opens today, I'll fix this for Ben by removing the mention 
of pref-wallet.dtd in the makefile.win, Makefile.in, and MANIFEST files found in 
the AIMGlue subdirectory. 

Comment 13

18 years ago
Tree never opened yesterday but it just opened today.  So the fix is now checked 
in.  Files affected are the following in ns/AIMGlue/resources/locale/en-US/pref.

makefile.win
Makefile.in
MANIFEST
pref-wallet.cpp

BTW, just curious as to what the 6/1 date meant on the nsbeta2+ designation.  
Did that mean that if we didn't fix this by 6/1, the preferences panels would be 
removed from the product?  :-/
Status: NEW → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 14

18 years ago
works now. verif using 2000.05.18.08 [opt comm] on winNT, linux and mac.
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.