crash when I run mail the first time after migrating.

VERIFIED DUPLICATE of bug 37256

Status

MailNews Core
Backend
P3
critical
VERIFIED DUPLICATE of bug 37256
18 years ago
10 years ago

People

(Reporter: (not reading, please use seth@sspitzer.org instead), Assigned: Stephen P. Morse)

Tracking

({crash})

Trunk
x86
Linux
crash

Firefox Tracking Flags

(Not tracked)

Details

#0  0x405184de in ?? () from /lib/libc.so.6
#1  0x40245935 in PR_Free (ptr=0xbfffcba0) at prmem.c:66
#2  0x401accc1 in nsAllocatorImpl::Free (this=0x805ade8, ptr=0xbfffcba0) at
nsAllocator.cpp:94
#3  0x401acdc4 in nsAllocator::Free (ptr=0xbfffcba0) at nsAllocator.cpp:160
#4  0x4004d6b2 in Recycle (aBuffer=0xbfffcba0 "") at
../../../dist/include/nsStr.h:489
#5  0x418f3231 in Wallet_Encrypt (text={<nsString> = {<nsStr> = {mLength =
3221212232, mCapacity = 148144776, mCharSize = 1100022144, mOwnsBuffer =
-1073754464,  = {mStr = 0xbfffcdb8 "", mUStr = 0xbfffcdb8}}, _vptr. = 0x0},
mBuffer =
"?\000\000\000\001\000\000\000\000\000\000\000`Ìÿ¿ÀÎ\037@\000\000\000\000\000Ï\037@\000\000\000\000\016\000\000\000hÖ\017\b\000\000\000\000\230Ìÿ¿¤\002\216A©ñ\032@Að\032@È7
@üÌÿ¿¨Ìÿ¿3£\026@\000\000\000\000\000\000\000\000È7
@üÌÿ¿ÈÌÿ¿~Ë\026@üÌÿ¿¸Íÿ¿\000\000\000\000È7 @üÌÿ¿¸Íÿ¿àÌÿ¿"}, crypt=@0x8d48288) at
wallet.cpp:1068
#6  0x418f3491 in Wallet_Encrypt2 (text={<nsString> = {<nsStr> = {mLength =
3221212412, mCapacity = 148144776, mCharSize = 1100022144, mOwnsBuffer =
-1073754464,  = {mStr = 0xbfffcf38 "", mUStr = 0xbfffcf38}}, _vptr. = 0x0},
mBuffer =
"?\000\000\000\001\000\000\000\000\000\000\000\024Íÿ¿ÀÎ\037@\000\000\000\000<Íÿ¿47\026@ð\201Ô\bDÍÿ¿Y,\035@`Íÿ¿\013{\036@\024\000\000\000Að\032@È7
@¸Íÿ¿\\Íÿ¿3£\026@\000\000\000\000\000\000\000\000È7
@¸Íÿ¿|Íÿ¿~Ë\026@¸Íÿ¿8Ïÿ¿\000\000\000\000È7 @¸Íÿ¿8Ïÿ¿\224Íÿ¿"}, crypt=@0x8d48288)
at wallet.cpp:1115
#7  0x418fd839 in si_Encrypt (text={<nsString> = {<nsStr> = {mLength =
3221212600, mCapacity = 148144776, mCharSize = 1100022144, mOwnsBuffer =
137528216,  = {mStr = 0x8cedb58 "\200\224ÌAT\224ÌA", mUStr = 0x8cedb58}}, _vptr.
= 0x14}, mBuffer = "È7
@\000\000\000\000?\000\000\000\001\000\000\000\000\000\000\000ÐÍÿ¿ÀÎ\037@\000\000
@©ñ\032@È7 @\002\000\000\000È7
@(Îÿ¿\200\001\221A\fÎÿ¿Y,\035@(Îÿ¿\013{\036@\024\000\000\000È7
@ Îÿ¿XÛÎ\b<Îÿ¿;¤\026@(Îÿ¿\002\000\000\000È7
@ Îÿ¿Ý3\026@\000\000\000\000\000\000\000\000\001\000\000"}, crypt=@0x8d48288) at
singsign.cpp:657
#8  0x41901576 in si_RememberSignonDataFromBrowser (URLName=0x8cef660
"imap---sspitzer-tintin", username={<nsString> = {<nsStr> = {mLength =
3221212984, mCapacity = 3221212832, mCharSize = 1100022144, mOwnsBuffer =
137528216,  = {mStr = 0x8cedb58 "\200\224ÌAT\224ÌA", mUStr = 0x8cedb58}}, _vptr.
= 0x8cfaef8}, mBuffer = "H\000\000\000\220Îÿ¿©X$@A\000\000\000È7
@¤Îÿ¿]Ì\032@A\000\000\000È7
@\000\000\000\000?\000\000\000\001\000\000\000\000\000\000\000¸Îÿ¿ÀÎ\037@\000\000ÿ¿Y,\035@ôÎÿ¿\013{\036@\024\000\000\000A\036(@¼¢(@Ð\201Ô\b\220\211Z@rF\026@¤\211Z@ \211Z@©ñ\032@È7
@\002\000\000\000\000\000\000\000@\000\000"}, password={<nsString> = {<nsStr> =
{mLength = 3221212832, mCapacity = 1100022144, mCharSize = 137528216,
mOwnsBuffer = 147774296,  = {mStr = 0x8cfaef8 "", mUStr = 0x8cfaef8}}, _vptr. =
0x48}, mBuffer = "\220Îÿ¿©X$@A\000\000\000È7 @¤Îÿ¿]Ì\032@A\000\000\000È7
@\000\000\000\000?\000\000\000\001\000\000\000\000\000\000\000¸Îÿ¿ÀÎ\037@\000\000ÿ¿Y,\035@ôÎÿ¿\013{\036@\024\000\000\000A\036(@¼¢(@Ð\201Ô\b\220\211Z@rF\026@¤\211Z@ \211Z@©ñ\032@È7
@\002\000\000\000\000\000\000\000@\000\000\000\000\000\000"}) at
singsign.cpp:2187
#9  0x41901dd4 in SINGSIGN_StorePassword (URLName=0x8cfaf00
"imap://sspitzer@tintin", user=0x0, password=0xbfffd134, strip=0) at
singsign.cpp:2294
#10 0x418ef355 in nsWalletlibService::SI_StorePassword (this=0x8328398,
URLName=0x8cfaf00 "imap://sspitzer@tintin", stripUrl=0, userName=0x0,
password=0xbfffd134) at nsWalletService.cpp:133
#11 0x418857e2 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/libmsgbaseutil.so
#12 0x41884dec in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/libmsgbaseutil.so
#13 0x417da38c in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libmailnews.so
#14 0x417d991f in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libmailnews.so
#15 0x417d8f80 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libmailnews.so
#16 0x417d113d in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libmailnews.so
#17 0x401bf8e9 in XPTC_InvokeByIndex (that=0x8cf3120, methodIndex=3,
paramCount=0, params=0xbfffdd20) at xptcinvoke_unixish_x86.cpp:159
#18 0x40611ebd in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libxpconnect.so
#19 0x40613ec7 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libxpconnect.so
#20 0x40099f86 in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libmozjs.so
#21 0x400ab04b in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libmozjs.so
#22 0x40099fe5 in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libmozjs.so
#23 0x4009a31c in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libmozjs.so
#24 0x4006db07 in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libmozjs.so
#25 0x4034fdc7 in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libjsdom.so
#26 0x4038ebcc in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libjsdom.so
#27 0x40fbfa81 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libraptorhtml.so
#28 0x40fc112e in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libraptorhtml.so
#29 0x4035b9fb in ?? () from /builds/seth/seamonkey/mozilla/dist/bin/libjsdom.so
#30 0x402a4b5f in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/libraptorwebwidget.so
#31 0x40ce8b09 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/liburiloader.so
#32 0x40ce8293 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/liburiloader.so
#33 0x40ce81c3 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/liburiloader.so
#34 0x40ce80f0 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/liburiloader.so
#35 0x40c4fe62 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libnecko.so
#36 0x40c5258b in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libnecko.so
#37 0x40c38668 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libnecko.so
#38 0x40c37c17 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libnecko.so
#39 0x401a246e in PL_HandleEvent (self=0x8c76248) at plevent.c:575
#40 0x401a231c in PL_ProcessPendingEvents (self=0x80e3708) at plevent.c:520
#41 0x401a3fc0 in nsEventQueueImpl::ProcessPendingEvents (this=0x80e36e0) at
nsEventQueue.cpp:316
#42 0x4079e494 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/libwidget_gtk.so
#43 0x4079e0df in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/libwidget_gtk.so
#44 0x4095c3ca in ?? () from /usr/lib/libglib-1.2.so.0
#45 0x4095da86 in ?? () from /usr/lib/libglib-1.2.so.0
#46 0x4095e041 in ?? () from /usr/lib/libglib-1.2.so.0
#47 0x4095e1e1 in ?? () from /usr/lib/libglib-1.2.so.0
#48 0x408877a9 in ?? () from /usr/lib/libgtk-1.2.so.0
#49 0x4079eac7 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/libwidget_gtk.so
#50 0x4066c484 in ?? () from
/builds/seth/seamonkey/mozilla/dist/bin/components/libnsappshell.so
#51 0x804ee84 in main1 (argc=2, argv=0xbffff954, splashScreen=0x0) at
nsAppRunner.cpp:758
#52 0x804f460 in main (argc=2, argv=0xbffff954) at nsAppRunner.cpp:975
#53 0x404d7cb3 in ?? () from /lib/libc.so.6

Comment 1

18 years ago
Seth - do you have save password set in 4.x before you migrate? I'm just getting 
steps so we can reproduce this in QA.
Severity: normal → critical
Keywords: crash
I do have remember password turned on, but since passwords aren't migrated, I'm 
not sure that would matter.

what seems to be happening is I migrate, run mailnews, and it tries to select 
my imap inbox, so it askes for my password.

due to recent changes, this requires PSM.  I'm not sure if me not having PSM 
installed (since this was a mozilla build) is related.  probably.  I'll try 
again with PSM installed
 
(Assignee)

Comment 3

18 years ago
Seth, can you give a detailed set of steps for reproducing this.  For example, I 
don't know offhand how to migrate.
to migrate, run mozilla -installer

I frequently migrate my 4.x profile, to make sure the migration code is 
working.  since we just copy and diverge the 4.x profile (but not alter it) 
this is ok.

on linux, I do this:
rm -rf ~/.mozilla
mozilla -installer
Tasks | Mail

Comment 5

18 years ago

*** This bug has been marked as a duplicate of 37256 ***
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → DUPLICATE

Comment 6

18 years ago
Mark it verified/dup.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.