W3C non-compliance for captions

RESOLVED DUPLICATE of bug 297676

Status

()

RESOLVED DUPLICATE of bug 297676
12 years ago
12 years ago

People

(Reporter: lmbrtgrg, Unassigned)

Tracking

1.8 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: ALL

Captions are supposed to stay within the 'boundaries' and keep the same width of a table. Under circumstances where the table is declared inside a div that is floated left or right, the caption does not adhere to the table (does not inherit the table's characteristics?). By this I mean that if you center the table the caption keeps its width and stays left and outside the table if the div is wider than the table. If you set the table width to 100% the caption does then can be centered. Alternatively the caption must be separately centered.

Reproducible: Always

Steps to Reproduce:
1.Simple example - create an XHTML page
2.Include the following (uses margin:0 auto; to center the table)
3.<div style="width:50%; float:left;"><table style="margin:0 auto;"><caption>some heading</caption><tr><td>content data</td></tr></table></div>
Actual Results:  
    Some Heading
             content data

Expected Results:  
             Some Heading
             content data

The caption can be centered if the table is set to 100% width
or
if the caption is also given the style="margin:0 auto"

but this means that the caption is not inheriting the table alignment attributes to stay within the boundaries of the table. Using a background color for the caption and table emphasises the slip.
(Reporter)

Comment 1

12 years ago
This happens on ALL firefox versions on ALL OSs.
Component: General → Layout: Tables
Product: Firefox → Core
QA Contact: general → layout.tables
Version: unspecified → 1.8 Branch
This is a duplicate of bug 297676, see the testcase in bug 309714, which was marked a duplicate of that bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 297676
You need to log in before you can comment on or make changes to this bug.