Last Comment Bug 371125 - Crash [@ nsXBLBinding::InstallAnonymousContent] on branch with testcase from bug 371124
: Crash [@ nsXBLBinding::InstallAnonymousContent] on branch with testcase from ...
Status: RESOLVED DUPLICATE of bug 350754
: crash
Product: Core
Classification: Components
Component: XBL (show other bugs)
: 1.8 Branch
: x86 Windows XP
: -- critical (vote)
: ---
Assigned To: xbl
: Hixie (not reading bugmail)
Mentors:
Depends on:
Blocks: stirdom 344056
  Show dependency treegraph
 
Reported: 2007-02-21 05:39 PST by Martijn Wargers [:mwargers] (not working for Mozilla)
Modified: 2007-03-22 15:59 PDT (History)
4 users (show)
See Also:
Crash Signature:
QA Whiteboard:
Iteration: ---
Points: ---
Has Regression Range: ---
Has STR: ---


Attachments

Description Martijn Wargers [:mwargers] (not working for Mozilla) 2007-02-21 05:39:04 PST
The unminimised testcase from bug 371124 is crashing branch builds in a different way.

To reproduce the crash:
- Extract the zipped testcase
- Open file 'parentframe.htm'

It should crash fairly quickly with a branch build (within 5 seconds or so, I think).

Talkback ID: TB29506005X
nsXBLBinding::InstallAnonymousContent  [mozilla/content/xbl/src/nsXBLBinding.cpp, line 207]
nsXBLBinding::GenerateAnonymousContent  [mozilla/content/xbl/src/nsXBLBinding.cpp, line 522]
nsXBLService::LoadBindings  [mozilla/content/xbl/src/nsXBLService.cpp, line 630]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7791]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructBlock  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 13246]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6891]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructTableCellFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 3978]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6878]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructBlock  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 13246]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6891]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ConstructTableForeignFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4072]
nsCSSFrameConstructor::TableProcessChild  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4252]
nsCSSFrameConstructor::TableProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4126]
nsCSSFrameConstructor::ConstructTableRowGroupFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 3716]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6842]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructBlock  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 13246]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6891]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ConstructTableForeignFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4072]
nsCSSFrameConstructor::TableProcessChild  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4252]
nsCSSFrameConstructor::TableProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4126]
nsCSSFrameConstructor::ConstructTableRowFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 3827]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6870]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructBlock  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 13246]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6891]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructTableCellFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 3978]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6878]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructBlock  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 13246]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6891]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ConstructTableForeignFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4072]
nsCSSFrameConstructor::TableProcessChild  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4252]
nsCSSFrameConstructor::TableProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 4126]
nsCSSFrameConstructor::ConstructTableRowGroupFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 3716]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 6842]
nsCSSFrameConstructor::ConstructFrameInternal  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7936]
nsCSSFrameConstructor::ConstructFrame  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 7748]
nsCSSFrameConstructor::ProcessChildren  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 12186]
nsCSSFrameConstructor::ConstructBlock  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line 13246]
nsCSSFrameConstructor::ConstructFrameByDisplayType  [mozilla/layout/base/nsCSSFrameConstructor.cpp, line
Comment 1 Mats Palmgren (:mats) 2007-02-22 14:25:50 PST
Crash due to infinite stack recursion on Linux.
I think this is one of the "recursive binding" bugs we have fixed on trunk,
eg bug 55070, bug 350754, I think Boris also fixed a few similar ones.
Comment 2 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-03-12 04:41:34 PDT
(In reply to comment #1)
> Crash due to infinite stack recursion on Linux.
> I think this is one of the "recursive binding" bugs we have fixed on trunk,
> eg bug 55070, bug 350754, I think Boris also fixed a few similar ones.

Ah, right, of course. I guess this should just be marked a duplicate of one of those bugs, not?
Comment 3 :Gavin Sharp [email: gavin@gavinsharp.com] 2007-03-22 15:36:18 PDT
This looks like a duplicate of one of those bugs to me.
Comment 4 Martijn Wargers [:mwargers] (not working for Mozilla) 2007-03-22 15:59:29 PDT
Yeah, I'm marking this a duplicate of bug 350754. No need to keep this security sensitive.

*** This bug has been marked as a duplicate of bug 350754 ***

Note You need to log in before you can comment on or make changes to this bug.