Need better UI for "Save all attachments"

RESOLVED WORKSFORME

Status

defect
P3
normal
RESOLVED WORKSFORME
19 years ago
12 years ago

People

(Reporter: bugzilla, Assigned: mscott)

Tracking

Trunk
Future
x86
All

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

Attachments

(2 attachments, 1 obsolete attachment)

(Reporter)

Description

19 years ago
After http://bugzilla.mozilla.org/show_bug.cgi?id=21742 got fixed this is a new 
bug report for the proper UI.
A lot of inspiration can be found in the attached image.
(Reporter)

Comment 1

19 years ago

Comment 2

19 years ago
Mail review recommends beta2 stopper.
Keywords: nsbeta2

Comment 3

19 years ago
Putting on [nsbeta2-] radar. Not critical to beta2.
Whiteboard: [nsbeta2-]

Comment 4

19 years ago
Targetting our beta2 candidates to M17.
Target Milestone: --- → M17

Comment 5

19 years ago
Scott, Jeff, is this just a trivial UI hookup, or is it a lot of work that isn't 
done yet?
Assignee: selmer → mscott

Updated

19 years ago
QA Contact: lchiang → pmock
(Assignee)

Comment 6

19 years ago
marking future. You can save all attachments today. we just don't have a great
UI that matches the spec for it. This isn't an area we are focusing on for beta3
/ rtm.
Target Milestone: M17 → Future
(Reporter)

Comment 7

19 years ago
What is the spec? Something like Outlook Express's cool Save All dialog?

Comment 8

19 years ago
Assign it to fenella@netscape.com
QA Contact: pmock → fenella

Comment 9

18 years ago
To Esther..
QA Contact: fenella → esther

Comment 10

18 years ago
Isnt this been checked in? I have a UI on mine? Shouldnt this be marked FIXED?

Comment 11

18 years ago
Marking FIXED  feel free to reopen it if you feel otherwise.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 12

18 years ago
In the current UI setup you can only save all the attachments.
Outlook Express has a cool UI where you can choose which attachments you would 
like to save.
Perhaps this is just a RFE...
Status: RESOLVED → REOPENED
Resolution: FIXED → ---
Summary: Need UI for "Save all attachments" → Need better UI for "Save all attachments"

Comment 13

18 years ago
Could someone explain me why this bug was considered as FIXED ? In 2001032904
Win32 build, there is no provision for it. Or maybe I misunderstood what the
purpose of this bug meant to be. Thanks.
(Reporter)

Comment 14

18 years ago
After the new mail&news diaplay has landed, the ability to save attachments has 
gone. There's another bug on that.

Comment 15

18 years ago
Marking dup of latest Save All bug 73414: "Once I check in the new look for
message display, I'm going to be breaking the save all attachments feature. I
need to re-implement this with the new view."





*** This bug has been marked as a duplicate of 73414 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 16

18 years ago
verified as dup
Status: RESOLVED → VERIFIED
(Reporter)

Comment 17

18 years ago
I'll reopen the bug since it's not a bug about implementing the "save all 
attachments" but a bug about improving the dialog.
Status: VERIFIED → REOPENED
Resolution: DUPLICATE → ---

Comment 18

18 years ago
See bug 65866.

Which should be marked as duplicate?
(Reporter)

Comment 19

18 years ago
*** Bug 65866 has been marked as a duplicate of this bug. ***

Comment 20

18 years ago
*** Bug 83965 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
*** Bug 102115 has been marked as a duplicate of this bug. ***

Updated

18 years ago
QA Contact: esther → trix

Comment 22

17 years ago
*** Bug 62223 has been marked as a duplicate of this bug. ***

Comment 23

17 years ago
Posted patch patch (obsolete) — Splinter Review
Textfield in dialog shows pathname, and label is changed from
"File name" to "Directory name".

Comment 24

17 years ago
Posted patch patch v2Splinter Review
I/F of nsIFile changed.
Attachment #74435 - Attachment is obsolete: true

Comment 25

17 years ago
It should (but does not):

- default to the last "save as" directory
- let you type a path
- let you create a directory (very needed)
- let you select 'some' items to save (maybe this is before the 'save all'
button is pushed, but anyway...)

Comment 26

16 years ago
*** Bug 192699 has been marked as a duplicate of this bug. ***

Comment 27

16 years ago
Is anyone still working on this or is it just stagnant? If noone is working on
it I would be glad to polish the current patch with Kevin Butler's suggestions.

Comment 28

16 years ago
the missing ability to create a directory can't be that hard - for windows os, 
mailnews uses a windows default dialog which has a flag to allow directory 
creation or not. so a patch for windows would be a one-liner, i think.
All with linux (gtk2)

Update: 1.4 has 
- create directory (see bug #205606)
- default to the last "save as" directory
- let you type a path

Mozilla Mail IMHO needs:
- let you select 'some' items to save (maybe this is before the 'save all'
button is pushed, but anyway...)
- If nothing is selected, take the current dir the dialog browser is in. This
would also fix bug #205606 and would be less strange. With the current behaviour
we have:
*click* Save all...
*click* Create Dir...
*click* Name dir...
*click* leave dir...
*click* select dir...
*click* Save
--------
The next time we get:
*click* leave dir...
*click* select dir...
*click* Save
to save in the very same directory... this is strange, at least.

Comment 30

15 years ago
For the moment simply enabling multiple select on the attachment listbox would
be satisfactory.
Product: Browser → Seamonkey

Comment 31

14 years ago
The linux and Windows dialogs here are completely different.  see bug 134634 for
linux-specific stuff.

Updated

14 years ago
Blocks: 205606

Comment 32

12 years ago
I think this issue is entirely resolved, at least on Win32.

Perhaps I'm missing something, but I believe in both TB and seamonkey (suite) the attachment listbox is multi-select. That addresses the major feature of the original OE dialog.

[On Win32] There is a dialog to select a folder, including a space to type a path, and a button to create a new folder.

http://integration.co.nz/download/SaveMultipleFiles.png

Closing this. 
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago12 years ago
Resolution: --- → WORKSFORME

Comment 33

12 years ago
I disagree with the choice to close it, but I do agree that the select multiple files & save as is a better UI than the "save all" UI.

Could you change the "save all" button to actually do a "select all" and then open the "save as" dialog with all the attachments selected?

I believe this would address the remaining concerns with the Save As dialog. (See above comments, including one from me, for those concerns.

Comment 34

12 years ago
Kevin, you said:
- default to the last "save as" directory
 - it does
- let you type a path
 - it does
- let you create a directory (very needed)
 - it does
- let you select 'some' items to save (maybe this is before the 'save all'
button is pushed, but anyway...)
 - it does (by selecting items in the listbox).

So I don't see what is remaining. Please clarify.
You need to log in before you can comment on or make changes to this bug.