libflashplayer.so appears to generate a SIGSEGV causing Firefox to core dump

RESOLVED INVALID

Status

External Software Affecting Firefox
Flash (Adobe)
--
critical
RESOLVED INVALID
11 years ago
8 years ago

People

(Reporter: Robert Bradbury, Unassigned)

Tracking

({crash})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.9) Gecko/20070201 SeaMonkey/1.0.7
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a2) Gecko/20070214 Firefox/3.0a2

Flash 7 was the plugin, libflashplayer.so dated 15 Dec 2006.

Neither Firefox had no "active" windows or tabs.  Firefox had been in the process of trying to debug Bug #263160 and was parked with was not actively in use.  There were 100 windows amd 586 tabs "open", YouTube videos had previously been displayed in several of the tabs.

It appears that the current libflashplayer.so may have a problem under Linux with current Linux (posix) thread shared libraries in glibc-2.5.

Reproducible: Didn't try

Steps to Reproduce:
1. Install latest Flash plugin from Adobe.
2. Play several YouTube videos.
3. Switch away from firefox (different programs, different workspaces, etc.).
4. Wait (at least an hour or more).
Javascript should be active (YouTube requires it I think).
Actual Results:  
Firefox is fine for a while then SegFaults.

Expected Results:  
Firefox should not SegFault after playing Flash videos.

Because libflashplayer.so doesn't seem to be compiled with DEBUG symbols the stack trace information is limited.  Bug probably needs to be sent to Adobe.  I have the firefox-bin binary and libraries (with all debug symbols) and the core dump but someone will need to contact me soon to obtain them (they will be deleted once disk space becomes limited).  Total size of all files involved is ~1.5GB.
URL: various
Component: General → Plug-ins
Keywords: crash
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → Trunk
(Reporter)

Comment 1

11 years ago
Created attachment 255917 [details]
Full strack trace of Firefox core dump most probably from libflashplayer.so

A brief examination seems to suggest that libflashplayer.so may have some conflict with Linux posix pthreads (glibc-2.5 version).

One could argue that after one has played a YouTube flash video the libflashplayer should be doing *nothing* until an explicit request is made to play another video.

Comment 2

11 years ago
What version of flash was this?

Updated

11 years ago
Attachment #255917 - Attachment mime type: application/octet-stream → text/plain

Comment 3

11 years ago
flash v7 for linux is known to crash.
does Flash 9.0 r31 solve your crash?
(Reporter)

Comment 4

11 years ago
The previous comments about Flash 7 were an error on my part.

Just to be clear about the version.  I believe it is the most recent release
from Adobe.

The Readme.txt file is dated 4 Jan 2007 and contains:
  Flash Player 9 for Linux
  Version 9.0.31.0
libflashplayer.so is 7,040,080 bytes in size, dated 15-Dec-2006 @ 16:51
and running a "sum libflashplayer.so" says:
  22534 6876


This is running under Gentoo Linux 2.6.18-r6 with all of the libraries at the
most recent release levels.  The glibc (and pthread) is at 2.5 with Posix
threads.  The GDK/GTK/GLIBs are at the most recent verions from gnome.org.

The problem is difficult to reproduce because flash was *not* supposed to be
running at the time of the segmentation fault (all previous videos from YouTube
had completed running hours prior to the SegFault, though the tabs were still
open).  The stack trace attached to the bug may be helpful.

If there is a specific location (with a symbol) in the libflashplayer.so that can be used to verify the Flash version # in the core dump, I'll be happy to do that.  (I've looked in the .so file for a string "version #" and there doesn't appear to be one present.)

I believe I have encountered a similar fault once before with the same version of flash, using almost the same system libraries, but using Firefox 2.0 instead of Version 3.0a2.

Comment 5

11 years ago
you can check the version of flash with about:plugins (also in the Help menu).
(Reporter)

Comment 6

11 years ago
Looking at about:plugins confirms that libflashplayer.so is indeed "Shockwave Flash 9.0 r31".

Comment 7

10 years ago
We can't reproduce this crash using the current Flash Player release (9r124) or the recent Flash Player 10 betas.  If it is reproducible, could someone post repro steps including URL, distro/version, browser/version and versions of relevant libraries?

Comment 8

9 years ago
closing invalid - no longer seen
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

8 years ago
Component: Plug-ins → Flash (Adobe)
Product: Core → Plugins
QA Contact: plugins → adobe-flash
Version: Trunk → unspecified
You need to log in before you can comment on or make changes to this bug.