UI blocks while deleting amout of messages in mailer about ~500.

RESOLVED DUPLICATE of bug 384360

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 384360
12 years ago
11 years ago

People

(Reporter: Sergey, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1 Mnenhy/0.7.4.0
Build Identifier: Mozilla/5.0 (OS/2; U; Warp 4.5; en-US; rv:1.8.1.2pre) Gecko/20070111 SeaMonkey/1.1 Mnenhy/0.7.4.0

UI blocks while deleting amout of messages in mailer about ~500. 

Reproducible: Always

Steps to Reproduce:
1. Delete from any mail folder amount of messages min 500.
2.
3.
Actual Results:  
Seamonkey UI blocks until operation complete.

Expected Results:  
Allow normal UI interaction

Comment 1

12 years ago
For the moment I find this hard to reproduce because I just don't have a folder with so many messages in it.

But can you give a few more hints:
- Did this only happen with SeaMonkey 1.1 and not with SeaMonkey 1.0 or
  one of the 1.1 betas?
- What type of account is it (IMAP, POP3, Local Folders)?
- Please try in a fresh setup where neither mnenhy nor any other extension
  is involved.
(Reporter)

Comment 2

12 years ago
It happens on ANY folder.
At least since Mozz ~1.4, if I recall correctly.
It happened w/o mnenhy as well.

(In reply to comment #1)
> For the moment I find this hard to reproduce because I just don't have a folder
> with so many messages in it.
> 

Comment 3

11 years ago
Sergey, have you tried with a fresh profile, where you only set up one account with a folder to test? Just to exclude possible interaction with a setting or extension... Also, what kind of system/CPU do you have?

I just thought of copying 500 messages from a newsgroup to a folder in the Local Folders account. I then marked 495 of them and pressed delete. They were removed almost instantaneously, in less than a second. I then created another folder in which I duplicated the messages from the Trash folder, so that I had more than 2000. Copying took a while but UI was never blocked. Removing them was a bit slower, too, but all the time I could see a message updating in the status bar which said, "Moving xxx of XXX messages to Trash".
(Reporter)

Comment 4

11 years ago
I think u should try "Compact folder" after copy/move/delete.
On new profile (w/o extensions) it appears on action ~1000 messages.

Comment 5

11 years ago
Hmm, in a debug build from trunk (which is a lot slower than an optimized build) I do see the problem at the end of the move operation, it blocks about 4s after moving 1500 messages. When then compacting the folder I see a message "Compacting folder <foldername>" and a progress bar, so then the UI it is not blocked.

Since February bug 384360 appeared which is about the same issue and has a lot more problem analysis in it. So the problem is not OS/2 specific and I can mark this as a dupe of the other one.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 384360
You need to log in before you can comment on or make changes to this bug.