Incorrect line break with floating element inside a table element

RESOLVED WORKSFORME

Status

()

Core
Layout: Tables
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: Fallen, Unassigned)

Tracking

({testcase})

1.8 Branch
testcase
Points:
---
Bug Flags:
in-testsuite +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(2 attachments)

(Reporter)

Description

11 years ago
Created attachment 256151 [details]
Testcase

Consider the attached testcase html.

I expect the image to be in the same line as the caption.

After some discussion on IRC it was found that this does not work in firefox 2.0.0.1 and 1.5.0.9 on windows and linux as well as todays windows build of minefield, but works fine in today's seamonkey linux build. Internet Explorer 6 also displays this as I expect it.

Note it sometimes works on the first load but as soon as you reload, it should show the unexpected behavior.

I am not sure what is correct w.r.t the css specs, but in any case the behavior should be the same at least on seamonkey and minefield.

Comment 1

9 years ago
is this wfm?
Keywords: testcase

Comment 2

9 years ago
Created attachment 373292 [details] [diff] [review]
reftest

(In reply to comment #1)
> is this wfm?

Yes, starting with Gecko 1.9.0. Since we're in line with other engines now, we should take care to not regress this.

The image used by the reftest is already in the reftest/bugs directory.
Attachment #373292 - Flags: review?(bernd_mozilla)

Updated

9 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Flags: in-testsuite?
Resolution: --- → WORKSFORME

Comment 3

9 years ago
Comment on attachment 373292 [details] [diff] [review]
reftest

http://hg.mozilla.org/mozilla-central/rev/753004a66668
Attachment #373292 - Flags: review?(bernd_mozilla) → review+

Updated

9 years ago
Flags: in-testsuite? → in-testsuite+
You need to log in before you can comment on or make changes to this bug.