If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

inline svg currenttranslate not functioning

RESOLVED DUPLICATE of bug 365901

Status

()

Core
SVG
RESOLVED DUPLICATE of bug 365901
11 years ago
10 years ago

People

(Reporter: SomeGuy, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.1) Gecko/20061208 Firefox/2.0.0.1

when using inline svg element ie
<svg:svg/> element inside <html> (served as xhtml)

the currentTranslate does not function, you can set and get values, but it doenst athcaly pan the view

currentTranslate works if svg is included via <object>

Reproducible: Always

Steps to Reproduce:
create html document with inline svg element
use ecmascript to alter that elements currentTranslate x and y properties
see addtionail info for verbatum html
Actual Results:  
doesnt pan

Expected Results:  
should pan.

<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Strict//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-strict.dtd">
<html xmlns="http://www.w3.org/1999/xhtml" xmlns:svg="http://www.w3.org/2000/svg" xml:lang="en" lang="en" dir="ltr">
<head>
	<meta http-equiv="Content-Type" content="application/xhtml+xml; charset=UTF-8" />
	<script type="application/ecmascript">
	window.onload = function()
	{
		document.getElementById("svg").currentTranslate.x = -100;
		document.getElementById("svg").currentTranslate.y = 100;
	}
	</script>
	</head>
<body>
	<svg:svg id="svg" version="1.1" width="400" height="400">
	<svg:rect x="50" y="50" width="200" height="200" fill="red"/>
	</svg:svg>
</body>
</html>
Assignee: nobody → general
Component: General → SVG
Product: Firefox → Core
QA Contact: general → ian
Version: unspecified → 1.8 Branch
(Reporter)

Comment 1

11 years ago
i checked alpha2 bulid with ff3 and the bug is there too
OS: Linux → All
Hardware: PC → All
Version: 1.8 Branch → Trunk
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 365901
You need to log in before you can comment on or make changes to this bug.