If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[FIX] Compile error with gcc on Windows XP

RESOLVED FIXED

Status

()

Core
Graphics
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: mats, Assigned: mats)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

fix
923 bytes, patch
Stuart Parmenter
: review+
Stuart Parmenter
: superreview+
Details | Diff | Splinter Review
(Assignee)

Description

11 years ago
Created attachment 256389 [details] [diff] [review]
fix

Trying to do a MSYS/mingw32 build of Firefox using gcc 3.4.2 I got:

g++ -mno-cygwin -o nsUnicodeRange.o -c  -DIMPL_THEBES -DMOZILLA_INTERNAL_API -DOSTYPE=\"WINNT5.1\" -DOSARCH=\"WINNT\" -DBUILD_ID=0000000000  -I../../../dist/include/cairo -I../../../dist/include/libpixman -I../../../dist/include/string -I../../../dist/include/pref -I../../../dist/include/xpcom -I../../../dist/include/unicharutil -I../../../dist/include/gfx -I../../../dist/include   -I../../../dist/include/thebes -I../../../dist/include/nspr  -DMOZ_PNG_READ -DPNG_NO_MMX_CODE -DMOZ_PNG_WRITE  -I../../../dist/sdk/include       -fno-rtti -fno-exceptions -Wall -Wconversion -Wpointer-arith -Wcast-align -Woverloaded-virtual -Wsynth -Wno-ctor-dtor-privacy -Wno-non-virtual-dtor -Wno-long-long -pedantic -mms-bitfields -pipe  -DDEBUG -D_DEBUG -DDEBUG_mats -DTRACING -g -O -I../../../dist/include/cairo    -DWINVER=0x501 -D_WIN32_WINNT=0x501 -D_WIN32_IE=0x0400 -DX_DISPLAY_MISSING=1 -DMOZILLA_VERSION=\"1.9a3pre\" -DMOZILLA_VERSION_U=1.9a3pre -DHAVE_SNPRINTF=1 -D_WINDOWS=1 -D_WIN32=1 -DWIN32=1 -DXP_WIN=1 -DXP_WIN32=1 -DHW_THREADS=1 -DSTDC_HEADERS=1 -DWIN32_LEAN_AND_MEAN=1 -DNO_X11=1 -D_X86_=1 -DD_INO=d_ino -DSTDC_HEADERS=1 -DHAVE_DIRENT_H=1 -DHAVE_GETOPT_H=1 -DHAVE_MEMORY_H=1 -DHAVE_UNISTD_H=1 -DHAVE_MALLOC_H=1 -DHAVE_LIBM=1 -DNO_X11=1 -DMMAP_MISSES_WRITES=1 -DHAVE_STRERROR=1 -DHAVE_SNPRINTF=1 -DHAVE_MEMMOVE=1 -DHAVE_RINT=1 -DVA_COPY=va_copy -DHAVE_VA_COPY=1 -DMOZ_EMBEDDING_LEVEL_DEFAULT=1 -DMOZ_EMBEDDING_LEVEL_BASIC=1 -DMOZ_EMBEDDING_LEVEL_MINIMAL=1 -DMOZ_PHOENIX=1 -DMOZ_BUILD_APP=browser -DMOZ_XUL_APP=1 -DMOZ_DEFAULT_TOOLKIT=\"cairo-windows\" -DMOZ_THEBES=1 -DMOZ_CAIRO_GFX=1 -DMOZ_DISTRIBUTION_ID=\"org.mozilla\" -DOJI=1 -DIBMBIDI=1 -DMOZ_VIEW_SOURCE=1 -DMOZ_XPINSTALL=1 -DMOZ_JSLOADER=1 -DNS_PRINTING=1 -DNS_PRINT_PREVIEW=1 -DMOZ_NO_XPCOM_OBSOLETE=1 -DMOZ_XTF=1 -DMOZ_MATHML=1 -DMOZ_ENABLE_CANVAS=1 -DMOZ_SVG=1 -DMOZ_SVG_FOREIGNOBJECT=1 -DMOZ_UPDATE_CHANNEL=default -DMOZ_PLACES=1 -DMOZ_FEEDS=1 -DMOZ_STORAGE=1 -DMOZ_SAFE_BROWSING=1 -DMOZ_URL_CLASSIFIER=1 -DMOZ_LOGGING=1 -DHAVE___CXA_DEMANGLE=1 -DMOZ_DEMANGLE_SYMBOLS=1 -DMOZ_USER_DIR=\"Mozilla\" -DHAVE_STDINT_H=1 -DHAVE_INTTYPES_H=1 -DHAVE_UINT64_T=1 -DMOZ_XUL=1 -DMOZ_PROFILELOCKING=1 -DMOZ_RDF=1 -DMOZ_MORKREADER=1 -DMOZ_DLL_SUFFIX=\".dll\" -DJS_THREADSAFE=1 -DMOZ_REFLOW_PERF=1 -DMOZ_REFLOW_PERF_DSP=1 -DMOZILLA_LOCALE_VERSION=\"1.9a1\" -DMOZILLA_REGION_VERSION=\"1.9a1\" -DMOZILLA_SKIN_VERSION=\"1.8\"  -UWIN32_LEAN_AND_MEAN -D_MOZILLA_CONFIG_H_ -DMOZILLA_CLIENT /c/moz/ff-trunk-msys-gcc/mozilla/gfx/thebes/src/nsUnicodeRange.cpp
c:/moz/ff-trunk-msys-gcc/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In member function `HFONT__* gfxWindowsFont::MakeHFONT()':
c:/moz/ff-trunk-msys-gcc/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:231: warning: comparison between signed and unsigned integer expressions
c:/moz/ff-trunk-msys-gcc/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp: In member function `virtual nsString gfxWindowsFont::GetUniqueName()':
c:/moz/ff-trunk-msys-gcc/mozilla/gfx/thebes/src/gfxWindowsFonts.cpp:450: error: call of overloaded `AppendInt(LONG&)' is ambiguous
../../../dist/include/string/nsTString.h:392: note: candidates are: void nsString::AppendInt(PRInt32, PRInt32)
../../../dist/include/string/nsTString.h:398: note:                 void nsString::AppendInt(PRUint32, PRInt32)
../../../dist/include/string/nsTString.h:407: note:                 void nsString::AppendInt(PRInt64, PRInt32)
...
(Assignee)

Comment 1

11 years ago
http://msdn.microsoft.com/workshop/misc/aimm/reference/structures/logfontw.asp
"LONG lfWeight;"
(Assignee)

Updated

11 years ago
Attachment #256389 - Flags: superreview?(pavlov)
Attachment #256389 - Flags: review?(pavlov)

Updated

11 years ago
Attachment #256389 - Flags: superreview?(pavlov)
Attachment #256389 - Flags: superreview+
Attachment #256389 - Flags: review?(pavlov)
Attachment #256389 - Flags: review+
(Assignee)

Comment 2

11 years ago
Checked in to trunk at 2007-02-27 14:18 PST.

-> FIXED
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED

Updated

11 years ago
Duplicate of this bug: 367742
You need to log in before you can comment on or make changes to this bug.