If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

Update to 2.0.0.2 from last 2.0 build enters never ending loop.

RESOLVED WORKSFORME

Status

()

Toolkit
Application Update
--
minor
RESOLVED WORKSFORME
11 years ago
9 years ago

People

(Reporter: anonymous, Unassigned)

Tracking

1.8 Branch
x86
Windows 2000
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

I was running the previous latest 2.0x build, and, Firefox wanted to update to the latest one released recently... this is the first time it has prompted and done the update itself. So, when I came to my machine it said Firefox was unable to process your update because may not have proper privileges to modify the files... or something like that. I searched for this error on google and all instances were from the previous year... this is the first time it failed to process the update, and, my system settings have been the same - so I can't say what the cause was. I closed all instances of the browser, but, the update just keeps repeating itself. I downloaded the latest Firefox install, and, even though no firefox.exe's were present it still wanted to close firefox a few times.. so it did, and, the new install did work from the actual setup and everything is fixed. Maybe it was just a fluke... but I felt like reporting it if it may be of use to the development team.. if you all wish, I could download the previous build and.. see if it updates itself. Hope I was able to be of some use =p

Reproducible: Always

Steps to Reproduce:
1. Run previous latest 2.x build
2. Let it auto update itself and apply update

Actual Results:  
Update will attempt to apply but give an error about insufficient permissions or something and restart. It will go through this loop infinitely.

Expected Results:  
Applied the update and ran normally.

I am the only user on this Win 2k installation, it is my machine, and I am the sole administrative user.
(Reporter)

Updated

11 years ago
Version: unspecified → 2.0 Branch
reporter, is this still an issue ? 

If so, can you post the complete error message ?

Comment 2

10 years ago
Duping to bug 340535 ?
not sure if this is a dupe of 340535. 

Reporter, do you try to update as normal user or as administrator ? 
Can you add the last-update.log (should be in the Update Directory in the Firefox Application Folder) to this bug ?
-> closing as works for me since its wfm for me in Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.9a6pre) Gecko/20070701 Minefield/3.0a6pre ID:2007070104 and Firefox 2.0.0.4 and also because of missing feedback here.

Reporter, if you're still seeing this, please comment with details and reopen. Please see comment #2 and comment #3.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WORKSFORME
(Assignee)

Updated

9 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.