session time-out pop-up notification window freezes Camino Version 2007022122 (1.1a2+)

VERIFIED WORKSFORME

Status

Camino Graveyard
Annoyance Blocking
VERIFIED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Michael Gorzka, Unassigned)

Tracking

Details

(Whiteboard: [CLOSEME - 3/11])

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070221 Camino/1.1a2+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070221 Camino/1.1a2+

When my online bank of america session times out, Camino freezes and must be force quit.

Reproducible: Always

Steps to Reproduce:
1.log into bankofamerica.com
2.let your session expire
3.you can read blocker message but cannot do anything with camino (must force quit)

Comment 1

11 years ago
Chris, I believe you were just today saying you use BoA; can you repro this?

Michael, can you get a sample of Camino while hung, as described at http://www.caminobrowser.org/support/bugzilla/#hang ?

Comment 2

11 years ago
I just tried, and I can't repro this - after my session times out, I get the JS sheet telling me so, and Camino continues to function normally.
(Reporter)

Comment 3

11 years ago
Created attachment 256541 [details]
camino (temporary) freeze after Bank of America timeout

It was just a temporary freeze this time. Camino froze again after BoA timed out. I did the activity monitor and got the report. When I returned to Camino I got the BoA "time out" message and was able to use Camino again.

Comment 4

11 years ago
It looks like it's just waiting for a response to the timeout sheet. Is the problem just that the rest of the browser doesn't respond until you dismiss the sheet?
(Reporter)

Comment 5

11 years ago
(In reply to comment #4)
> It looks like it's just waiting for a response to the timeout sheet. Is the
> problem just that the rest of the browser doesn't respond until you dismiss the
> sheet?
> 
Is the timeout sheet the bar at the top of the web browser window with the "allow once" and "never" buttons? If so, it didn't respond at all. Nor did any other part of the Camino browser. After the browser froze, I tried clicking on the buttons to "allow once" and so forth. None of them worked. A few minutes later (after I did the activity monitor) the BoA timeout window appeared and Camino was unfroze.

Comment 6

11 years ago
Hm, maybe I'm not understanding how the timeout notification works. Is the timeout window you describe a browser window, or a small floating dialog window?

Comment 7

11 years ago
Ah, I see Ian's comment that is indeed a sheet. The sheet would be a small dialog attached to your BoA window, telling you that your session has timed out.
It almost sounds, from what I understand of the description, that the pop-up blocker ("Allow Once" "Never") and the session timeout sheet are somehow blocking?

Comment 9

11 years ago
Yeah, I've never had a problem with this in the past. I'll take a look now.

OK, I have an idea what might be going on here.

BoA throws a popup when the timeout is imminent. If that popup is being blocked, you'll (in theory) get the popup blocker (I'm gonna have to re-test in a second to see what the deal is here). About 30 seconds or so later, it throws a JS sheet on the BoA tab (or window).

Neither of them locked up the UI for me, but I'm gonna re-enable the popup blocker and try again.

cl

Comment 10

11 years ago
OK, I can't repro this with a fresh profile either.

Michael, the thing you're talking about that got locked up -- if you copy this into your location bar and hit return, does it look like what this generates:

javascript:alert("This is an alert sheet");

or does it look like this:

https://bugzilla.mozilla.org/attachment.cgi?id=239560

cl
Michael, can you please respond to comment 10?
Whiteboard: [CLOSEME - 3/11]
Closing WFM due to lack of updates.  If you are still experiencing this problem with a recent nightly build and can supply the requested additional information, you may reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Updated

11 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.