Camino 1.1 Command+# Bookmark Bar Shortcuts override Keyboard Shortcuts set in System Prefs

RESOLVED FIXED in Camino1.5

Status

--
minor
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: belthesar, Assigned: stuart.morgan+bugzilla)

Tracking

({fixed1.8.1.4})

unspecified
Camino1.5
PowerPC
Mac OS X
fixed1.8.1.4

Details

Attachments

(1 attachment, 1 obsolete attachment)

v2
2.43 KB, patch
mikepinkerton
: superreview+
Details | Diff | Splinter Review
(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070223 Camino/1.1b
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070223 Camino/1.1b

Camino 1.1's implementation of the Command+# allowing you to quickly access links in your Bookmark Bar does not allow Command+# Keyboard Mappings assigned in the Keyboard System Preferences pane to take precedence.  

Reproducible: Always

Steps to Reproduce:
1.  Assign a custom Keyboard Shortcut to a Command+# shortcut (IE: Previous tab to  Command+1, Next Tab to Command+2)
2.  Test Shortcut
Actual Results:  
Bookmarks bar link for the shortcut pressed opened.

Expected Results:  
Keyboard Shortcut to perform said setup shortcut.

A suggestion to work around the issue is to put the shortcut capture inside of a menu within the Bookmarks bar instead of being captured by the window.  This would (in theory) allow the Keyboard Shortcuts Prefpane to override it if a user wished it so, and advertise the function better than just having it in a Changelog.
Confirming. This is at least something we should look at.
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Assignee)

Comment 2

12 years ago
I wasn't sure if this would be fixable, but if we can we definitely should. I don't know if there's any way to find out if the there is a menu command assigned a given shortcut (short of scanning all the menus at startup, which might work if nothing else will).

Comment 3

12 years ago
I could have sworn we talked about this (in a bug, even) and decided it wasn't possible to fix it, but I might be remembering wrong. I'm gonna CC pink, though, 'cause I think he was in on the discussion.
(Reporter)

Comment 4

12 years ago
I know the statement about wanting Camino to be lightweight and all of that, but would it be possible to make this option toggleable within the preferences?  The feature is nice, but I could certainly do without it.
(Assignee)

Comment 5

12 years ago
(In reply to comment #4)
> would it be possible to make this option toggleable within the preferences?

Theoretically yes, but if we did that every time someone could do without a given feature we'd have hundreds of hidden prefs, so we only do it when we really feel it's necessary.
(Reporter)

Comment 6

12 years ago
Thanks for all the fast responses here.  I've pretty much resolved that I will need to make the necessary code modifications and build Camino myself with the changes I wish it to have.  However, since I haven't worked on the project, I don't know what part of the project I need to open.  

If anyone could send me an e-mail in regards to what section of code I should be looking through, or even an educated guess as to where I need to look (as I have yet to find it browsing through the XCode project file) I would certainly appreciate the help.
(Assignee)

Comment 7

12 years ago
Created attachment 257026 [details] [diff] [review]
fix

For our compatibility shortcuts (numbers, D for add bookmark), give the menubar first crack at it in case someone has added the shortcut to a menu item, and then handle it only if the menubar didn't.
Assignee: nobody → stuart.morgan
Status: NEW → ASSIGNED
Attachment #257026 - Flags: review?
(Assignee)

Updated

12 years ago
Keywords: regression
Target Milestone: --- → Camino1.1

Comment 8

12 years ago
Comment on attachment 257026 [details] [diff] [review]
fix

It seems to me that we should let the menu have first crack at Cmd-+ too.  Also, this patch doesn't apply cleanly.  r=me with those changes.
Attachment #257026 - Flags: review? → review+
(Assignee)

Comment 9

12 years ago
Created attachment 257686 [details] [diff] [review]
v2

Respun, and including Command-+
Attachment #257026 - Attachment is obsolete: true
Attachment #257686 - Flags: superreview?(mikepinkerton)
Comment on attachment 257686 [details] [diff] [review]
v2

sr=pink
Attachment #257686 - Flags: superreview?(mikepinkerton) → superreview+
(Assignee)

Comment 11

12 years ago
Checked in on trunk and MOZILLA_1_8_BRANCH.
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Keywords: regression → fixed1.8.1.4
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.