Need longer location entry text area

RESOLVED FIXED

Status

Webtools
Bouncer
--
blocker
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: preed, Assigned: morgamic)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

11 years ago
On the file location text area on http://download.mozilla.org/admin/locations.php, there's a maxlength of 100 characters.

With the partner builds, we're running into that limit, and now can no longer serve partial updates and complete updates for Linux (because their path specification is over 100 characters).

I'm hoping this is just some weird UI thing, and we can fix it easily, and not a database constraint.

You're our only hope, morgamic...
(Reporter)

Comment 1

11 years ago
(BTW, this is blocker because it's blocking the release of 1.5.0.10 partner updates.)

Comment 2

11 years ago
I have no idea how where this limit is implemented, but we should make sure we
investigate the web interface as well as any back-end database and/or
configuration that might be affected by a change to that limit.  

I don't think I can handle any more bustage with this release...
OS: Linux → All
Hardware: PC → All
Created attachment 256558 [details] [diff] [review]
patch - v1

Change the max to 255 to match the maximum length allowed in the db.
Attachment #256558 - Flags: review?(morgamic)
(Assignee)

Updated

11 years ago
Attachment #256558 - Flags: review?(morgamic) → review+
(Assignee)

Comment 4

11 years ago
Jay, the form input was set to 100 max, but the db dump from production has a max length of 255.  The patch lets them match up.  There's no unknown regression from this simple change.

Thanks Reed for posting the fix!  You da man!  I've checked in the patch and emailed oncall.  Should be updated shortly.

IT: need to update the bouncer1 tag on the OSL cluster.  It should already be pulling from the 1.0-prod-02082007 tag.
(Assignee)

Updated

11 years ago
Depends on: 371872
(Assignee)

Comment 5

11 years ago
Was updated in production and I verified that we can add a 100+ character location_path.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.