Message list loses focus (becomes deselected) when deleting e-mails too fast

RESOLVED DUPLICATE of bug 268098

Status

SeaMonkey
MailNews: Message Display
RESOLVED DUPLICATE of bug 268098
11 years ago
11 years ago

People

(Reporter: Gene Pavlovsky, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070212 SeaMonkey/1.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.1.2pre) Gecko/20070212 SeaMonkey/1.1

First of all, there's around 0.5-1 second delay between a click on a message in the message list and it's contents being displayed. Sometimes when I have to delete several sequential messages, I just select the top one on the list and press the delete key several times. Because of that 0.5-1 second delay, it looks quite sluggish. Recently (don't remember if it ever happened before seamonkey 1.1), I got this problem: if I press the delete key fast enough (well, not really fast, anyway), a message gets deleted before it has a chance to display, and the selection disappears. I.e. nothing is selected in the messages list, I have to click the top message to select it again. The selection should stay where it was no matter what happens. Thanks for the great product, hope to see this fixed.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
dupe of "selected moves to none instead of next when deleting mail (the focus gets lost instead of going to the next message after deleting a msg)"
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Version: unspecified → Trunk
Duplicate of bug: 268098
You need to log in before you can comment on or make changes to this bug.