redirect /(show_bug.cgi?id=\d+)\./ and similar pages to $1

RESOLVED DUPLICATE of bug 295458

Status

()

Bugzilla
Bugzilla-General
--
enhancement
RESOLVED DUPLICATE of bug 295458
11 years ago
11 years ago

People

(Reporter: Jeremy Baron, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
On several occasions I've clicked a link or double clicked text (possibly with dragging ) to select a text URL and a period at the end (because the URL happened to be the end of a sentence) was gobbled up too.  I'd like to solve this by redirecting /(show_bug.cgi?id=\d+)\./ and similar pages to $1 on bmo and if it is acceptable in bugzilla proper.  Also the same issue applies for linkification of URLs in comment body on bugs.  (Yes, I've seen people tack periods on the end there too.  I'm pretty sure they were gobbled up in bugzilla as well.)  That should probably be it's own bug, but I'm not filing that tonight :(

Comment 1

11 years ago
show_bug.cgi?id=123456. is not the same as show_bug.cgi?id=123456 as '123456.' is a valid bug alias (i.e. with a trailing period). You would break all installations having bug aliases of the form \d+\. even if it is probably pretty rare to use such aliases (but who knows?).
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

11 years ago
(In reply to comment #1)
Yes, I realize that, but in every production instance I've seen (granted only a handful) aliases are relatively rarely used. (I think I heard bmo has ~200 and it has 370000+ bugs) Also, I've never seen an alias of a form that would come anywhere close to being an issue here IRL.

I discussed this with justdave briefly on irc and I don't think he had any objections.  This is something that could easily be fixed at time of upgrade (although maybe we don't want to add to the steps required to upgrade from the admin perspective) or could be made an instance specific option.  Not quite sure what the policy is for either of those issues.  (adding options or adding questions on upgrade)
Status: RESOLVED → REOPENED
Resolution: WONTFIX → ---
(Reporter)

Comment 3

11 years ago
Also, I think but have not verified that many similar pages do not accept aliases in place of bug nums.  In those cases this could be done without having to worry about those alias edge cases.

Comment 4

11 years ago
(In reply to comment #2)
> This is something that could easily be fixed at time of upgrade
> (although maybe we don't want to add to the steps required to upgrade from the
> admin perspective) or could be made an instance specific option.

Altering existing aliases is bad. And we are not going to have an option for such a thing.

Comment 5

11 years ago
(In reply to comment #3)
> Also, I think but have not verified that many similar pages do not accept
> aliases in place of bug nums.  In those cases this could be done without having
> to worry about those alias edge cases.

ValidateBugID() automatically converts aliases to bug IDs, so you can use them everywhere (at least you should).

Comment 6

11 years ago
One compromise could be to fall back to \d+ only if \d+\. doesn't exist as alias (e.g. fall back to bug 123456 only if there is no bug with '123456.' as alias). Else you would go to the bug with this alias, as it currently does.
Status: REOPENED → NEW

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 295458
You need to log in before you can comment on or make changes to this bug.