Transparent windows with an element using a flex attribute looses colors

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: daniel, Unassigned)

Tracking

({testcase})

Trunk
x86
Windows XP
testcase

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(3 attachments)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a3pre) Gecko/20070226

When trying to set a semi transparent window containing element with a flex attribute, the whole windows looses it's color information.

A testcase can be found at http://www.birgin.de/test/bugzilla/transpwin_flex_bug.xul (Should be started with chrome privileges in a separate window)

Without setting the flex attribute the window looks like this:
http://www.birgin.de/test/bugzilla/transpwin_noflex.gif
The lower area is fully transparent. The green border of the vbox ends below the buttons.

Setting the vbox's flex attribute to have a continuous semi transparent background, results in the following:
http://www.birgin.de/test/bugzilla/transpwin_flex.gif
The bottom area gets filled, but the top color and labels looses their colors and clicks on elements will go through and to the underlaying window.

Reproducible: Always
(Reporter)

Comment 1

12 years ago
Created attachment 256614 [details]
Window showing the error. Flex attribute set.
(Reporter)

Comment 2

12 years ago
Created attachment 256615 [details]
Window without flex attribute - no error.
(Reporter)

Comment 3

12 years ago
Created attachment 256616 [details]
XUL testcase
(Reporter)

Comment 4

12 years ago
The problem actually doesn't seem to be the flex attribute but the content's height. If that is the same height as the window or up to 2px lower, the effect is visible. Setting the difference to 3px or more works:

<vbox style="height:247px; background-color:#fff; -moz-opacity:0.8;">

However, using a 3px different results in a 1px fully transparent line at the bottom of the window.
Version: unspecified → Trunk
(Reporter)

Comment 5

12 years ago
A complete testcase including the used xulrunner build for windows can be downloaded from http://www.birgin.de/test/bugzilla/winbug.zip
Just run start.bat and click on the "Show that bug" button to show the transparent window.

(You may remove the "kirschkern" folder in your personal 'application data' directory after removing the testcase.)
You get these prolems on trunk or branch?
On trunk, for some reason, I'm even able to click on the buttons.
(Reporter)

Comment 7

12 years ago
I'm getting this with the latest XULRunner nightly trunk:
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a3pre)
Gecko/20070226

Yes, I'm also able to click on the buttons, but the titlebar isn't responding anymore but the click is going through.
Thanks for that correction.
(Reporter)

Comment 8

12 years ago
It's still reproducable in the latest trunk:
Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.9a3pre) Gecko/20070320
(Reporter)

Updated

12 years ago
Keywords: testcase

Updated

11 years ago
Blocks: 357052
Daniel, this seems to be fixed in current trunk builds. (it is fixed for me even in a 2007-04-03 build, I could see the problem in a 2007-03-01 build)
Could you perhaps retest?
(Reporter)

Comment 10

11 years ago
(In reply to comment #9)
> Daniel, this seems to be fixed in current trunk builds.

Yes, it works for me too! Thanks for the hint. Didn't noticed any process here. I mark it fixed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.