Open Bug 371922 Opened 13 years ago Updated 3 years ago

"Server Timeout Alert" dialog should continue to test for availablity, and if connection becomes available clear the alerts and reconnect to Server

Categories

(MailNews Core :: Networking: POP, enhancement)

enhancement
Not set

Tracking

(Not tracked)

UNCONFIRMED

People

(Reporter: 210525p42015, Unassigned)

References

Details

User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: TB version 1.5.0.9 (20061207)

As with many bugs reported in the Server Timeout realm, this occurs when one has many POP servers and many accounts to check.

In particular, this MacBook Pro 2.16 gig Core-Duo is on a Broadband connection.

If the DSL connection is unavailable temporarily for reasons such as computer sleep for 10 minutes or current Streaming Internet Radio is hogging, or whatever, then TB issues a myriad of Alerts .... yet, at the moment the user is trying to close each and every window, the connection is available and obvious to the user.

I propose that IF TB needs to go to Alert mode and issue a window with the 'Server Timed Out' message type, that a connection-functionality-check function be activated. This function could return a simple boolean.

If the connection appears open, then all the alert windows could be closed and check-for-new-mail could be serviced again.

TB could gather some near-term statistics, say within twenty minutes, and make a crude evaluation of the need to check for email/nntp again if some threshold is passed.

Worst case is that the obnoxious and ambiguous windows would all line up, as they do now. Best case is that the user would return and new mail would be available. 

Reproducible: Always

Steps to Reproduce:
1.uplug your dsl line
2.check for mail
3.plug your DSL line back in
"TB could gather some near-term statistics, say within twenty minutes, and make
a crude evaluation of the need to check for email/nntp again if some threshold
is passed." -

As 'connection error' alert window is a way to inform user about network unavailability occurred at any time and as its totally a user's choice whether to be informed about network unavailability or not, so  
I think it will be better if a Timeout property is applied to that Alert window , just like this picture "http://bp1.blogger.com/_3-3xVN2ELS8/ReQ7ots1wrI/AAAAAAAAABI/ZGopd7YDOjA/s1600-h/Timeout_Button.jpg"

Both timeout value and enabling/disabling of this property should be controlled by  preferences.
This feature should be disabled by default.

Any user who doesn't want to be informed about network unavailability while he/she is not using TB, can enable this pref. so that he/she can get rid of those pop ups .
Having experienced this 'feature' for several months with two accounts on a server that would regularly be down for 90-120 minutes each evening, I can attest to the fact that Tb's current behaviour is annoying, distracting, and disruptive.

The root of the problem seems to be that Tb is using a Stupid Modal Alert (despite |user_pref("browser.xul.error_pages.enabled", true);|) to inform the user of the server time-out.

An alert showing on the status bar, somewhat like how Fx gives information about S/HTTP sites, should be adequate (an actual error page would likewise be disruptive).

It would make sense to me that, after a certain number of failed connexions (say, five), the user would be informed of the fact and perhaps be given some possible options from which to choose (/e.g./, continue checking; check again in [30|60] minutes; stop checking till the next time Thunderbird is started).
Frobozz, Please set OS to 'All'
Related to Core bug 82999? See also bug 223131 -> Core bug 123440.
Assignee: mscott → nobody
in oct 2009 this is still a major annoyance. I have several accounts; the DSL goes off and TB tries all email accounts, one at a time, and makes me close each pop-up window ... even when the DSL comes back on !!
Severity: enhancement → minor
OS: Mac OS X → All
Hardware: PowerPC → All
zug's suggestion seems quite reasonable
Status: UNCONFIRMED → RESOLVED
Closed: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 123440
was too hasty in duping
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
Duplicate of this bug: 407906
Severity: minor → enhancement
Component: Mail Window Front End → Networking: POP
Product: Thunderbird → MailNews Core
Summary: "Server Timeout Alert" should notice reconnect to Server → "Server Timeout Alert" dialog should continue to test for availablity, and if connection becomes available clear the alerts and reconnect to Server
You need to log in before you can comment on or make changes to this bug.