Can't enter anything into compose mail unless I restart the program

RESOLVED INCOMPLETE

Status

Thunderbird
Message Compose Window
RESOLVED INCOMPLETE
12 years ago
10 years ago

People

(Reporter: O, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2008-11-06)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Thunderbird version 1.5.0.9 (20061207)

Every so often after I've had Thunderbird open for a while if I try to write a email. The To line turn gray, the subject line turns gray and the enter body area and the tools turn gray in color and unusable. They only become usable if I completely shut down the program and restart it. 

Reproducible: Sometimes

Steps to Reproduce:
1.leave the program open for a while
2.try to compose an email
3.
Actual Results:  
It makes it impossible to compose an email. Type in an email address to send email to anyone or fill in the subject line.

Expected Results:  
allowed me to put in an email address,compose an email with out restarting the program

Comment 1

12 years ago
Do you see an error in the JavaScript Console, similar to those reported at 
bug 307672?  
See also bug 366482, which is a Thunderbird bug for a similar symptom.

Rather than restarting the program, try simply opening a second message compose window while the broken one is displayed.  I think you then want to close the broken one first; subsequent messages should be OK.

If you can come up with consistent steps to reproduce that don't involve "leave the program open for a while," we'd love to hear them.
(Reporter)

Comment 2

12 years ago
opening another window does nothing. Every window simply does it until you restart the program

Comment 3

12 years ago
And... is there an error in the JavaScript Console?

Also: do you have extensions installed?  If so, does the problem occur if you run Thunderbird in Safe Mode?

Comment 4

11 years ago
I have also experienced this same issue, so I thought I should chime in. I'm running Thunderbird 1.5.0.10 (20070221) on Win XP Pro. 

I was also having to restart Thunderbird every time this happened. Until I read your suggestion to open another reply window. That apparently reset whatever was wrong, and I can go on with replying and forwarding as necessary. 

In terms of causes, I have tried various things to see if they affect anything. But I haven't come up with anything helpful. All I can say is that it just starts happening after awhile. Sometimes it happens when the computer has been left idle for a time, and sometimes it starts within an hour of starting Thunderbird, even with intermittent use of Thunderbird.

I have not tried running in Safe Mode. 

I am running a couple extensions:
- AdBlock Plus (ver 0.7.2.4)
- Lightning (ver 0.3.1)
- URL Link (ver 2.00.3)


Comment 5

11 years ago
I am in the same situation, and have the same build, as MikeM, comment #4.  Javascript console reports:

Error: [Exception... "Component returned failure code: 0x80004003 (NS_ERROR_INVALID_POINTER) [nsIMsgCompose.initEditor]"  nsresult: "0x80004003 (NS_ERROR_INVALID_POINTER)"  location: "JS frame :: chrome://messenger/content/messengercompose/MsgComposeCommands.js :: InitEditor :: line 3499"  data: no]
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 3499

Error: gMsgCompose.editor has no properties
Source File: chrome://messenger/content/messengercompose/MsgComposeCommands.js
Line: 148

My extensions:

- AdBlock Plus (ver 0.7.2.4)
- Delete Junk Context Menu (ver 0.3.2)
- Nokia Synchronisation (1.0.29)
- Update Notifier (0.1.5.2)

I haven't tried running in same mode either.

Updated

10 years ago
Assignee: mscott → nobody
Reporter, does this issue still occur in the latest supported 2.0.0.x / Shredder trunk nightlies?

(1.5.0.x is now end-of-life and the latest supported 2.0.0.x is now 2.0.0.17)
Whiteboard: closeme 2008-11-06
RESO INCO per lack of response to last question. If you feel this change was made in error, please respond to the bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.