Blank login/password form even if login/password are available - gcc 4.1.1 related ?!

RESOLVED INVALID

Status

()

--
major
RESOLVED INVALID
12 years ago
10 years ago

People

(Reporter: fredbezies, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.8.1.2) Gecko/20060601 Firefox/2.0.0.2 (Ubuntu-edgy)
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; fr; rv:1.8.1.2) Gecko/20060601 Firefox/2.0.0.2 (Ubuntu-edgy)

I cannot get any login + password on pages. The best test I have is to used bugzilla front page and login form. 

The "Remember Password" dialog box in Preferences is blank but my signons2.txt file is far from being empty. 

When I open it in gedit or any other text editor (with firefox closed of course), I can see every single login and scrambled password I am using.

When I need to use any password based site (like bugzilla or any webmail), I couldn't !

I entered before a bug (bug 363159) which was closed as invalid, because it couldn't be reproduced with every single official nightly I downloaded :(

I am opening a new bug because firefox is now completely useless to me. And as there is no official x86_64 nigthly, I have to build one on my computer. And official nightly are not working without having 10 or 20 lines of warning.

Also, Error console is empty.

Is the problem related to gcc 4.1.1 ? I built a firefox using this .mozconfig (nearly copied/pasted from official build options) :

#
# See http://www.mozilla.org/build/ for build instructions.
#

. $topsrcdir/browser/config/mozconfig

# Options for 'configure' (same as command-line options).
ac_add_options --enable-optimize="-Os -gstabs+"
ac_add_options --disable-debug
ac_add_options --disable-tests

ac_add_options --enable-canvas
ac_add_options --enable-svg
ac_add_options --enable-pango
ac_add_options --enable-default-toolkit=cairo-gtk2

ac_add_options --enable-static
ac_add_options --disable-shared

ac_acc_options --enable-update-channel=nightly 
ac_add_options --enable-update-packaging

I launched it from command line and get this error message on start :

(Gecko:20907): libgnomevfs-WARNING **: Fonction obsolète. Les modifications d'utilisateur sur la base MIME ne sont plus supportées.

Quick translation :

(Gecko:20907): libgnomevfs-WARNING **: Obsolete function. User modifications on MIME base are not supported anymore.

The only workaround is to use firefox 2.0.0.2 (built by ubuntu developpers) to enter bugzilla and fill this report. 

Could it be related to bug 360493 in some ways ?! Just guessing of course ! :)

Some "technical" infos :

* Profile freshly created (1 day ago), so it couldn't be corrupted, I hope !

* Source up-to-date at :

checkout finish: thursday 1st march 2007, 06:07:17 (UTC+0100)

* gcc version used :

$ gcc -v
Using built-in specs.
Target: x86_64-linux-gnu
Configured with: ../src/configure -v --enable-languages=c,c++,fortran,objc,obj-c++,treelang --prefix=/usr --enable-shared --with-system-zlib --libexecdir=/usr/lib --without-included-gettext --enable-threads=posix --enable-nls --program-suffix=-4.1 --enable-__cxa_atexit --enable-clocale=gnu --enable-libstdcxx-debug --enable-mpfr --enable-checking=release x86_64-linux-gnu
Thread model: posix
gcc version 4.1.2 20060928 (prerelease) (Ubuntu 4.1.1-13ubuntu5)

* ubuntu linux version used :

$ cat /etc/issue.net 
Ubuntu 6.10

* Gnome : 2.16.1

I will do a debug build, and copy / paste the log here. I hope it could help having the answer on a long standing bug I am facing (both with 32 and 64 bits builds), because the first bug report was created in december 2006 :(


Reproducible: Always

Steps to Reproduce:
1.grab source code
2.build firefox using a gcc 4.1.1 based distro (like ubuntu edgy eft for example)
3.launch newly built firefox and try to login to bugzilla or any other site you have already entered both login and password
Actual Results:  
No autofill of login form :(

Expected Results:  
autofill and firefox waiting for you to validate these entries
(Reporter)

Comment 1

12 years ago
Created attachment 256900 [details]
debug log using ./firefox >& debug.log &

I am adding a debug log made using this .mozconfig :

#
# See http://www.mozilla.org/build/ for build instructions.
#

. $topsrcdir/browser/config/mozconfig

# Options for 'configure' (same as command-line options).
ac_add_options --enable-debug

ac_add_options --enable-canvas
ac_add_options --enable-svg
ac_add_options --enable-pango
ac_add_options --enable-default-toolkit=cairo-gtk2

I launched the build, loaded bugzilla front page, and then, I went to edit / preferences / show password.

I see this related to password files :

###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173
###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173
###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173
###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173
###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173
###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173
###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173
###!!! ASSERTION: nsSecureBrowserUIImpl not thread-safe: '_mOwningThread.GetThread() == PR_GetCurrentThread()', file nsSecureBrowserUIImpl.cpp, line 173

Could be this an answer to the problem I am facing ?!
(Reporter)

Comment 2

12 years ago
Note : I noticed that applying the patch named " Patch for trunk (FF3)" (attachement 256438) seems to fix the bug.

Just to make the situation a little clearer.
(Reporter)

Updated

12 years ago
Depends on: 360493
(In reply to comment #0)
> The "Remember Password" dialog box in Preferences is blank but my signons2.txt
> file is far from being empty. 

Trunk builds will not read signons2.txt, because the patch for bug 360493 hasn't landed on the trunk (see bug 360493 comment 371). It will likely land tomorrow.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.