install link has always-English "for" if platform-specific

RESOLVED FIXED

Status

RESOLVED FIXED
12 years ago
3 years ago

People

(Reporter: clouserw, Unassigned)

Tracking

Details

(URL)

(Reporter)

Description

12 years ago
For example, http://remora.stage.mozilla.com/sk/firefox/addon/9

[On Linux] the green button says "$extension for Linux" no matter what language you're in.  (iirc, this is coming out of js somewhere)

Comment 1

12 years ago
Here, the green button says "install" (localized), and when an extension is not available for a specific OS, it also says so (localized as well).

In short, I can't reproduce. Is the problem still present for you?
(Reporter)

Comment 2

12 years ago
The example in the original post is still valid - the word "for" is in english
Resummarizing, because we really really don't want the platform names localized; it makes breakage.

(Could we just say "Install now ($PLATFORM)" and avoid the "for" issue entirely without adding another localized string?  Bet we could!)
Summary: OS sometimes added to install link isn't localized → install link has always-English "for" if platform-specific
Not only could we, we did in r3581
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
Component: Add-ons → Administration
QA Contact: add-ons → administration
(Assignee)

Updated

3 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.