Ability to select a permanent default profile, only temporarily overridden by -P

RESOLVED DUPLICATE of bug 198726

Status

SeaMonkey
Startup & Profiles
--
enhancement
RESOLVED DUPLICATE of bug 198726
11 years ago
10 years ago

People

(Reporter: Greg Colyer, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061211 SeaMonkey/1.0.7
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.9) Gecko/20061211 SeaMonkey/1.0.7

Want to be able to specify a permanent default profile to be used when no -P flag is specified. Temporary use of a different profile, requiring -P flag or manual selection in Profile Manager, should not change this default, i.e. next time no flag is specified the permanent default should be selected again, not the last used profile.

Useful for a rarely used (e.g. administrative) profile "hidden" from ordinary users and where legacy shortcuts, scripts, etc. do not specify -P flag.

Reproducible: Always

Steps to Reproduce:
1. Normal operation in profile X (no selection using Profile Manager or -P)
2. Run once in profile Y using Profile Manager or -P
3. Run again with no selection
Actual Results:  
At step 3, profile Y used.

Expected Results:  
At step 3, profile X used.
(Reporter)

Comment 1

11 years ago
Such a profile would only be hidden from ordinary users if ordinary users never use the Profile Manager, probably implying that there is only one ordinary profile.

An alternative enhancement that would be useful with multiple ordinary profiles (e.g. single user accounts shared by several humans): the ability to create a "hidden" profile that does not appear in the Profile Manager and never becomes the default.

In the above steps, X would then be X or Z (with selection used), Y would be the hidden profile, and the desired behaviour at step 3 would be to return to the last used of X or Z, but not Y.

Updated

10 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 198726
You need to log in before you can comment on or make changes to this bug.