Thunderbird exit without removing .parentlock when lost X11 connection

RESOLVED WORKSFORME

Status

RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: jose.aliste, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: closeme 2010-07-15)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.7) Gecko/20060913 Fedora/1.5.0.7-1.fc5 Firefox/1.5.0.7 pango-text
Build Identifier: 1.5.0.7 (20060913)

I have a thin client which is acting as a X11 server. I run thunderbird in a server. If the thin client is dead(and thus X11 connection is lost) then thunderbird will quit without removing .Parentlock. Thus, when you restart thunderbird you have the message "thunderbird is running but is not responding. please close thunderbird, etc....." which is very annoying, because there is no thunderbird process running in the server and a typical user doesn't can not fix this in ay easy way. 

Reproducible: Always

Steps to Reproduce:
1.Start thunderbird in a server with a thin client as X11 display 
2.kill the thin client
3.Try to start thunderbird again
Actual Results:  
you can not start thunderbird and you get the message mentionated above. 

Expected Results:  
you can start thunderbird again

Comment 1

12 years ago
I'm also experiencing the same problem in both Thunderbird and Firefox
Assignee: mscott → nobody

Comment 2

10 years ago
I also got hit by this. That message "Thunderbird is running but not responding" should give the user some information on what the lockfiles are, or point them to eg http://kb.mozillazine.org/Profile_in_use .

It should also have a button to confirm "No, TB is *not* running, please killall any undead TB processes, and forcibly remove the lockfiles".


[As a partial workaround, I run this from rc.local on the server]
shopt -s nullglob
COUNT=0
for file in /home/*/.mozilla/firefox/*.default/lock 
/home/*/.mozilla/firefox/*.default/.parentlock  
/home/*/.thunderbird/*.default/lock 
/home/*/.thunderbird/*.default/.parentlock ; do
        mv -f $file $TRASH
done

Comment 3

10 years ago
Here is a rather ugly, but properly working solution. It works on Linux, and copes correctly with both TB and FX.  (Should be easy to generalise to sunbird too). Tests OK on Mandriva and Ubuntu. GPL'd shell script, well commented.

http://www.richardneill.org/src/fix_fxtb_lock_wrapper.sh

Install by doing:
sudo ./fix_fxtb_lock_wrapper.sh installwrapper

That's all you have to do, though you'll need to re-install it every time you update your system-wide copies of fx or tb.

(If you don't use a distro-provided copy of Fx/Tb, then edit the BINARIES variable to suit.)

Comment 4

8 years ago
Is this seen in version 3?
Whiteboard: closeme 2010-07-15
RESOLVED INCOMPLETE due to lack of response to previous question. If you feel this change was made in error, please respond to this bug with your reasons why.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE

Comment 6

8 years ago
(In reply to comment #4)
> Is this seen in version 3?

It now seems to be ok. My test is as follows:

TB normally lives on machine "desktop"; I also have a client machine "client".
On client:
1.  ssh -X desktop
       thunderbird

2.  killall -9 ssh   #a bit later, in different shell.

3.  ssh -X desktop
     thunderbird


Thunderbird starts correctly both times. 
So I think you can close this bug as fixed.
RESOLVED WFM per comment 6.
Resolution: INCOMPLETE → WORKSFORME
You need to log in before you can comment on or make changes to this bug.