font-style: italic; regression on trunk

RESOLVED DUPLICATE of bug 333126

Status

()

Core
Graphics
P2
normal
RESOLVED DUPLICATE of bug 333126
11 years ago
10 years ago

People

(Reporter: Robert Sayre, Unassigned)

Tracking

({regression, testcase})

Trunk
regression, testcase
Points:
---
Dependency tree / graph
Bug Flags:
blocking1.9 +

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(6 attachments)

(Reporter)

Description

11 years ago
On the branch, the page in the URL field displays with italics on OS X and Linux. It is not italicized on trunk. The computed style seems to be correct.
Works for me on Linux nightly 2007-03-02-04-trunk.  (The word "intertwingly" is in italics.  If the expected results are different, it would be nice if you described "Actual results" and "Expected results" more clearly in the bug report.)
(Reporter)

Comment 2

11 years ago
> it would be nice if you described "Actual results" and "Expected results" more clearly in the bug report.

Actual:   Not italicized.
Expected: Italicized.
(Reporter)

Comment 3

11 years ago
Created attachment 257046 [details]
Screenshot: Firefox 2
(Reporter)

Comment 4

11 years ago
Created attachment 257047 [details]
Screenshot: Minefield (up-to-date trunk)
(Reporter)

Comment 5

11 years ago
Created attachment 257049 [details]
Screenshot: Firefox 2 Mac
(Reporter)

Comment 6

11 years ago
Created attachment 257050 [details]
Screenshot: Minefield Mac Nightly
Yeah, I see it on Mac.  We might want separate bugs per platform.

Comment 8

11 years ago
AFAIK there are several fonts (among them "Arial Black" and
"Bitstream Vera Serif") which lack italic. Depending upon
how the fonts are mapped on your systems (or by the mozilla
build you're using) this may trigger the behaviour
described in this bug.
(Reporter)

Comment 9

11 years ago
(In reply to comment #8)
> AFAIK there are several fonts (among them "Arial Black" and
> "Bitstream Vera Serif") which lack italic. 

Yes, could be bug 364713.

Comment 10

11 years ago
Yes, also seeing this with trunk Camino 2007032200 (1.2+). Lucida Grande text won’t italicize because there is no actual italic variant, so synthesis is failing I suppose.
Created attachment 291758 [details]
simple italic testcase

I'm seeing this bug with the default font (serif) on Linux.

See attached testcase...
 expected: italic text
 observed: normal text
(In reply to comment #11)
> I'm seeing this bug with the default font (serif) on Linux.

FWIW, FF2/Linux renders attachment 291758 [details] correctly (italicized) using the same font that's broken in FF3, serif.
Flags: blocking1.9?
Keywords: regression, testcase
Flags: blocking1.9? → blocking1.9+
Priority: -- → P2
(In reply to comment #11)
> I'm seeing this bug with the default font (serif) on Linux.

Interesting... Two other linux boxes I've tested work fine.  I only see the problem in FF3 builds (not FF2) specifically on my main dev machine.

All three computers run Ubuntu 7.10 Gutsy.  Not sure what's causing the difference.
Created attachment 292695 [details]
simple italic testcase 2 (using "Bitstream Vera Serif")

In this testcase, I specify a specific Linux font-family: Bitstream Vera Serif.

This fails (straight text) in FF3 on all three Linux boxes that I'd previously tested, and works in FF2.
... and from looking at this site:

  http://www.bitstream.com/font_rendering/products/dev_fonts/vera.html

...it looks like Bitstream Vera Serif is the only Bitstream Vera font without an Oblique/Italic version.

So, as mentioned in Comment 10, this is probably an issue with synthesizing italics for fonts with no italic variant.
Probably a gfx bug.
Component: Layout: Fonts and Text → GFX: Thebes
QA Contact: layout.fonts-and-text → thebes

Comment 17

10 years ago
i think this is 364713 on mac and 333126 on linux
(In reply to comment #17)
> i think this is 364713 on mac and 333126 on linux

Those bugs are ranked P3 and P5, respectively. Either those bugs should be promoted to higher-priority (particularly 333126, the P5), or we should reduce the priority of this bug.

(Or, we could just resolve this as a dupe)
Depends on: 333126, 364713
(In reply to comment #18)
> (In reply to comment #17)
>> i think this is 364713 on mac and 333126 on linux

Just a follow up to my previous comment:

Those bugs are now marked P3 and P2, respectively -- cool.  They're also both assigned.

I don't think anything more is needed for this bug. --> resolving as a dupe.
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 333126
You need to log in before you can comment on or make changes to this bug.