Closed Bug 372426 Opened 18 years ago Closed 17 years ago

[FIX]automatic page redirection broken on 64-bit build

Categories

(SeaMonkey :: General, defect, P1)

x86
Linux
defect

Tracking

(Not tracked)

RESOLVED FIXED
seamonkey2.0a1

People

(Reporter: romosan, Assigned: bzbarsky)

References

Details

(Keywords: regression)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a3pre) Gecko/20070302 Mozilla/1.5a
Build Identifier: Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a3pre) Gecko/20070302 Mozilla/1.5a

for the last month or so (the last checkout from cvs that i had working was on February 7, 2007) automatic page redirect has stopped working for my 64-bit cvs seamonkey build (works fine for 32-bit builds). I think the patch to Bug 83265 (Add a way to disable HTTP-EQUIV=refresh) broke it but i haven't been able to come up with a fix.

Reproducible: Always

Steps to Reproduce:
1. go to a page that redirects to another page

Actual Results:  
first page displays forever, browser never redirects to the intended target.
Assignee: general → nobody
Blocks: 83265
Component: General → Embedding: Docshell
Product: Mozilla Application Suite → Core
QA Contact: general → docshell
Version: unspecified → Trunk
I don't think this is a core issue...
Assignee: nobody → general
Status: UNCONFIRMED → NEW
Component: Embedding: Docshell → General
Ever confirmed: true
Product: Core → Mozilla Application Suite
QA Contact: docshell → general
So as far as I can tell, nsBrowserStatusFilter::OnRefreshAttempted returns a random value if mListener doesn't QI to nsIWebProgressListener2.  Or am I missing something?

This doesn't bite in Firefox presumably because whatever listener (nsBrowserStatusHandler?) is involved was changed to implement that interface.  But in Seamonkey that wasn't done.  So nsBrowserStatusFilter probably needs fixing.
Attached patch Patch to testSplinter Review
Does this fix the bug?
Attachment #257267 - Flags: superreview?(cbiesinger)
Attachment #257267 - Flags: review?(pilgrim)
Attachment #257267 - Flags: review?(cbiesinger)
Comment on attachment 257267 [details] [diff] [review]
Patch to test

(I haven't tested this)
Attachment #257267 - Flags: superreview?(cbiesinger)
Attachment #257267 - Flags: superreview+
Attachment #257267 - Flags: review?(cbiesinger)
Attachment #257267 - Flags: review+
I haven't either -- I don't have a 64 bit system.  Alex, does this fix things for you?
(In reply to comment #5)

i've tested it remotely since my 64-bit machine is at work and it seems to work. i'll try again tomorrow when i sit in front of my desktop but i expect it to work as well. so, this probably fixes the bug.
Assignee: general → bzbarsky
Priority: -- → P1
Summary: automatic page redirection broken on 64-bit build → [FIX]automatic page redirection broken on 64-bit build
Target Milestone: --- → seamonkey1.5alpha
i've also tested it locally and page redirection works again so i would say the fix is good. thanks.
Comment on attachment 257267 [details] [diff] [review]
Patch to test

Mark is apparently no longer active.
Attachment #257267 - Flags: review?(pilgrim)
Checked in.
Status: NEW → RESOLVED
Closed: 17 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Created:
Updated:
Size: