Software Update is restarting indefinitely - Fail to install the update each time

VERIFIED DUPLICATE of bug 452162

Status

--
critical
VERIFIED DUPLICATE of bug 452162
12 years ago
10 years ago

People

(Reporter: robert.vergnes, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Thunderbird 1.8.20061.20700

Each Time I now start Thunderbird, I have a window which says:
Sofwtare Update / Thunderbird is installing .... - then goes to the end,
then another window appears saying
Software update failed - "One or more files could not be updated", please make sure all other application are closed and that you have permission to modify files and then restart Thunderbird and try again"
Software Update is restarting indefinitely - Fail to install the update each time.
I am looged as administrator on my WinXP and I do have all rights.
It is REALLy very annoying as now I have no access to my emails !


Reproducible: Always

Steps to Reproduce:
1. It happended to me in the past few month ago and the only way was to re-install thunderbird - after having un-installed it !
2.Is there some other way around this problem ?
3.WIll it do that each time there is updates ?
Actual Results:  
I cannot use Thunderbird as each time I start thunderbird it goes directly to installing the software update and then fails to do so,. and then loop indefinitely trying to update and failing to do so.

Expected Results:  
I expect that the update would install normally and that I would be able to use Thudnerbird !
:-)

updater.exe - 1.8.20061.20700
from the update.xml file:
 <updates xmlns="http://www.mozilla.org/2005/app-update">
- <update type="minor" name="Thunderbird 1.5.0.10" version="1.5.0.10" extensionVersion="1.5.0.10" detailsURL="http://www.mozilla.com/thunderbird/releases/1.5.0.10.html" licenseURL="undefined" serviceURL="https://aus2.mozilla.org/update/1/Thunderbird/1.5.0.9/2006120700/WINNT_x86-msvc/en-US/release/update.xml" installDate="1172844324437" statusText="Install Pending" buildID="2007022120" isCompleteUpdate="true">
  <patch type="complete" URL="http://download.mozilla.org/?product=thunderbird-1.5.0.10-complete&os=win&lang=en-US" hashFunction="SHA1" hashValue="a27865a89ab5570d8e5218778c888e90933a65c1" size="7769460" selected="true" state="pending" /> 
  <patch type="partial" URL="http://download.mozilla.org/?product=thunderbird-1.5.0.10-partial-1.5.0.9&os=win&lang=en-US" hashFunction="SHA1" hashValue="84642efb6ad80447df06a0aa63f4867f43717a20" size="953690" selected="false" state="download-failed" /> 
  </update>
  </updates>
from the active-update.xml file:
<updates xmlns="http://www.mozilla.org/2005/app-update">
- <update type="minor" name="Thunderbird 1.5.0.10" version="1.5.0.10" extensionVersion="1.5.0.10" detailsURL="http://www.mozilla.com/thunderbird/releases/1.5.0.10.html" licenseURL="undefined" serviceURL="https://aus2.mozilla.org/update/1/Thunderbird/1.5.0.9/2006120700/WINNT_x86-msvc/en-US/release/update.xml" installDate="1172844324437" statusText="Install Pending" buildID="2007022120" isCompleteUpdate="true">
  <patch type="complete" URL="http://download.mozilla.org/?product=thunderbird-1.5.0.10-complete&os=win&lang=en-US" hashFunction="SHA1" hashValue="a27865a89ab5570d8e5218778c888e90933a65c1" size="7769460" selected="true" state="pending" /> 
  <patch type="partial" URL="http://download.mozilla.org/?product=thunderbird-1.5.0.10-partial-1.5.0.9&os=win&lang=en-US" hashFunction="SHA1" hashValue="84642efb6ad80447df06a0aa63f4867f43717a20" size="953690" selected="false" state="download-failed" /> 
  </update>
  </updates>
Duplicate of bug 300922?
Version: unspecified → 1.5
Duping to the cause.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 340535
Status: RESOLVED → VERIFIED
Duplicate of bug: 452162
You need to log in before you can comment on or make changes to this bug.