hang on viewing certain rdf page

RESOLVED WORKSFORME

Status

()

Core
General
--
major
RESOLVED WORKSFORME
11 years ago
8 years ago

People

(Reporter: Elmar Stellnberger, Unassigned)

Tracking

({hang})

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.2) Gecko/20070221 SUSE/2.0.0.2-6.1 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.1.2) Gecko/20070221 SUSE/2.0.0.2-6.1 Firefox/2.0.0.2

??

Reproducible: Always

Steps to Reproduce:
1. go to http://www.iswc2006.semanticweb.org/projects/semdis/swetodblp/january2007/swetodblp_january_2007_part_33.rdf
2.
3.
Actual Results:  
crash
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
It stays in a loading state "transferring data from..".
On branch it doesn't crash or hang but after closing Firefox the process stays in the task manager. I don't see the latter problem in trunk.
(Reporter)

Comment 2

11 years ago
After a while Firefox ceases to redraw its window. If I try to close Firefox my window manager KWin is going to complain that Firefox will not react. Then KWin suggests to terminate Firefox. Precisely speaking it is a hang not a crash.
(Reporter)

Comment 3

11 years ago
Perhaps it is necessary to open an additional plain tab before trying to fetch that page in order to obtain a hang.
Summary: crash on viewing certain rdf page → hang on viewing certain rdf page
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a3pre) Gecko/20070302 Minefield/3.0a3pre ID:2007030204 [cairo]
My trunk build doesn't like loading the link.

Updated

11 years ago
Severity: critical → minor
Keywords: hang

Comment 5

9 years ago
kinda sucks memory
Severity: minor → major
Component: General → General
Product: Firefox → Core
QA Contact: general → general
Version: unspecified → Trunk

Comment 6

8 years ago
Keep in mind that it's a 14MB XML file that Firefox tries to display pretty-printed. It actually opens for me in a couple of minutes without being more laggy than what its 1GB footprint requires.

For comparison, I didn't manage to click through Chrome's "the page hung" windows enough times to see the page.

(This is Mozilla/5.0 (Macintosh; U; Intel Mac OS X 10.5; en-US; rv:1.9.3a2pre) Gecko/20100224 Minefield/3.7a2pre, 2 year old Macbook with 2GB RAM.)

So why is our resource usage unreasonable? Does anyone does better?

If the issue is blocking the UI, it's a duplicate of out-of-process tabs bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.