Font weight in a div rendered lighter than normal depending on following content

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
12 years ago
4 years ago

People

(Reporter: emeraldjunk-firefox, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.10 (Macintosh; Intel Mac OS X; U; en)
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2


The details are posted in this forum (my post: subopt) http://smoothgallery.jondesign.net/forums/viewtopic.php?id=90 and you can see the difference here, which is what I described in the post. 

http://subopt.com/ff/ok.html
and 
http://subopt.com/ff/bad.html

Basically the letters " O O O O O" are rendered too light-weight when the slideshow component is included. 

There's obviously some JS and CSS involved, but I have been unable to narrow this problem down further. The real annoying thing is that the font weight also changes when the slideshow is timed and creates a distraction on the page I am working on.

Reproducible: Always

Steps to Reproduce:
1. Download http://smoothgallery.jondesign.net/files/SmoothGallery-1.0.1.tar.gz and extract

2. in demo.html add the following div (colors etc just so that the effect is easy to see) around line 18 (before the <script>..., position doesn't really matter):
<div style="background-color: #c9242b;color: white; line-height: 20px;">  O O O O O O O O </div>

3. Now load demo.html and pay attention to the font weight (the boldness) of the letters "O O O O O O"

4. Change <div id="myGallery"> to e.g. <div id="Not_myGallery"> (just something so that SmoothGallery does not find the slide show) and reload. The weight should now look bolder (actually at their normal weight)
Actual Results:  
Letters "O O O O O " are rendered too leight-weight when slide show component is activated. 

Expected Results:  
Font-weight should be same as when slideshow component is not activated or not included.

When you make the viewport very small so that you can scroll around the page it is possible to make the font weight appear right, just scroll the "O O O O O" out of sight and back into sight a couple of times. It also may be displayed to light-weight again.

For me this happens when running on a 20" Apple Studio Display (1680 x 1050 resolution I believe) connected to a MacBook Pro. On a G5 w/ 1024 x 768 I could not reproduce this problem - may be something with the resolution, DPI, who knows? Windows seems to be ok, other browsers as well.

Thank you.

Comment 1

4 years ago
font weight WFM on recent FF Mac.
if problem is still occurring, please upload a testcase.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 4 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.