If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

[Vista] Web pages bounce/shake/jump when "Bookmarks Toolbar Items" is empty

RESOLVED FIXED in Firefox 3 alpha6

Status

()

Firefox
Toolbars and Customization
RESOLVED FIXED
11 years ago
10 years ago

People

(Reporter: BLAKE HAHN, Unassigned)

Tracking

Trunk
Firefox 3 alpha6
x86
Windows Vista
Points:
---
Bug Flags:
blocking-firefox3 -
wanted-firefox3 +

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: http://kb.mozillazine.org/Window_shakes)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

google, google advanced search, some firefox pages are jiggling up and down. nvidia 256 video card in use. recent java auto update. tabs wont finish loading, firefox stops responding.  intermittant problem. vista ultimate dell inspiron laptop 

Reproducible: Sometimes

Steps to Reproduce:
1.google.com
2.search
3.load 2 or 3 links onto tabs
Actual Results:  
google page jiggles up and down, tabs quit loading, message firefox not responding

Expected Results:  
smooth page visual, tabs load, no lockup

i just tried google advanced search again, still jiggling, opened 3 link tabs succesfully, no lockup
Blocks: 352420
Duplicate of this bug: 372719

Comment 2

11 years ago
I have similar symptoms but it is not limited to google pages.  It occurs on all pages and with 1-3 tabs open.  (I haven't tried any more than 3.) I also am using an Nvidia 256 card.  My tabs do load completely but the screen is difficult to read because of the jiggle.  Am using Vista Home premium and a Core 2 Duo 6300 system from Dell.
Duplicate of this bug: 373757
Duplicate of this bug: 374902

Comment 5

11 years ago
Just installed a new Theme: Metal Lion - vista 1.5 and the jumping "jiggle" is gone. I was using the "default" theme previously... So of course I tried the solution with one more theme but I get the "jiggle" also.

So... all I can say is that with the aforementioned theme I have no more problems.

Gal

Comment 6

11 years ago
Metal Lion 1.5 Vista worked on my system.  Would like work to continue so I can use any theme but this may provide some insight into the issue.  

Thanks to Gal Nitzan. 

Tom
Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.8.1.3) Gecko/20070309 Firefox/2.0.0.3

Can you give steps to reproduce for the jiggle for I don't see it. I loaded 3 Google search results in new tabs but it makes no move at all. Dupe of Bug 247116?

Comment 8

11 years ago
All I have to do is load firefox and I get the jiggle on all screens in all tabs using all pages/sites except when using the Metal Lion theme and then the screen is very stable in all tabs and all pages.  I think it may have to do with Windows Vista (I am using Home Premium) and the Nvidia drivers.  I am also using a Core 2 Duo E6300 processor.  Let me know what other configuration information you would like to have and I will provide it. 

Updated

10 years ago
Duplicate of this bug: 385411

Updated

10 years ago
Status: UNCONFIRMED → NEW
Component: Tabbed Browser → Toolbars
Ever confirmed: true
QA Contact: tabbed.browser → toolbars
Summary: screen "jiggle" and firefox lockup while loading tabs → [Vista] Web pages bounce/shake/jump when "Bookmarks Toolbar Items" is empty
Version: unspecified → Trunk

Updated

10 years ago
Duplicate of this bug: 384191
For some reason, I thought this was fixed on the branch.
Flags: blocking1.8.1.5?
Flags: blocking-firefox3?
Whiteboard: http://kb.mozillazine.org/Window_shakes
as ispiked pointed out in bug #384191:  see bug #178884
not blocking 1.8.1.5, but I imagine if we had a low risk work around, we would consider it.
Flags: blocking1.8.1.5?

Comment 14

10 years ago
I also have giggling when opening first address. Afterwards, other pages are okay
This is wanted, but not a blocker, as the STR aren't really a common path (the bookmark toolbar needs to be present-but-empty).
Flags: blocking-firefox3? → blocking-firefox3-
Whiteboard: http://kb.mozillazine.org/Window_shakes → http://kb.mozillazine.org/Window_shakes [wanted-firefox3]
dave, did your patch for bug #247116 fix this?
Bug 247116 went in for Firefox 2.0.0.4 so if it's still being seen on branch firefox then I imagine not. However I do not have Vista handy to be able to try to reproduce this.
Dave, sorry for the confusion.  To clarify, I meant:

Did your port of the fix in #247116 to mozilla/browser/components/places/content/toolbar.xml (patch at https://bugzilla.mozilla.org/attachment.cgi?id=269862) happen to fix bug #384191 (marked as dup of this bug) for Trunk Vista?

The original report in this bug was for fx 2002, but this bug seems to now cover trunk/vista.

swon (since you can see it), can you confirm the fix for trunk/vista?
Just tried it on Vista.
1. Started a new profile.
2. Removed all items in bookmarks toolbar.

Result before: Content window starts jumping around.
Result now: Toolbar quickly resizes by a few pixels, and no more bouncing.

So, I guess this might have fixed it Seth.
Based on steve's comments, marking as fixed for A6.  

(Credit going to Dave Townsend.)
Status: NEW → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
Target Milestone: --- → Firefox 3 alpha6
Ok confusing, yeah my patch is quite likely to have cleaned up an issue with an empty places toolbar causing bouncing. However I'm somewhat surprised that a bug on trunk with the places toolbar was duped to one on branch with the normal toolbar.

Comment 22

10 years ago
I guess this is my fault. I thought this bug tracked the shaking issue on Vista, which I thought might've been perturbed by something specific to how we do theming in Vista, but apparently it was just due to the fix not being ported over to Places yet (in the bugs I duped to this, at least). Sorry.
Flags: wanted-firefox3+
Whiteboard: http://kb.mozillazine.org/Window_shakes [wanted-firefox3] → http://kb.mozillazine.org/Window_shakes
You need to log in before you can comment on or make changes to this bug.