Compile error in "intl/uconv/native/nsNativeUConvService.cpp"

RESOLVED FIXED

Status

()

Core
Internationalization
--
major
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Priit Laes, Assigned: smontagu)

Tracking

Trunk
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment, 1 obsolete attachment)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en; rv:1.8.1.2) Gecko/20070302 Epiphany/2.18 BonEcho/2.0.0.2
Build Identifier: xulrunner CVS

I am trying to build xulrunner from CVS and run into following errors:

nsNativeUConvService.cpp: In member function 'virtual nsresult IConvAdaptor::SetOutputErrorBehavior(PRInt32, nsIUnicharEncoder*, PRUnichar)':
nsNativeUConvService.cpp:253: error: reference to 'kOnError_Signal' is ambiguous
../../../dist/include/uconv/nsIUnicodeEncoder.h:139: error: candidates are: nsIUnicodeEncoder::<anonymous enum> nsIUnicodeEncoder::kOnError_Signal
../../../dist/include/uconv/nsIUnicodeDecoder.h:100: error:                 nsIUnicodeDecoder::<anonymous enum> nsIUnicodeDecoder::kOnError_Signal
nsNativeUConvService.cpp:253: error: reference to 'kOnError_Signal' is ambiguous
../../../dist/include/uconv/nsIUnicodeEncoder.h:139: error: candidates are: nsIUnicodeEncoder::<anonymous enum> nsIUnicodeEncoder::kOnError_Signal
../../../dist/include/uconv/nsIUnicodeDecoder.h:100: error:                 nsIUnicodeDecoder::<anonymous enum> nsIUnicodeDecoder::kOnError_Signal
nsNativeUConvService.cpp: In member function 'virtual nsresult NativeUConvService::GetNativeConverter(const char*, const char*, nsISupports**)':
nsNativeUConvService.cpp:378: error: 'nsRefPtr' was not declared in this scope
nsNativeUConvService.cpp:378: error: expected primary-expression before '>' token
nsNativeUConvService.cpp:378: error: 'ucl' was not declared in this scope
gmake[5]: *** [nsNativeUConvService.o] Error 1
gmake[5]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-1.9_pre20070304/work/mozilla/intl/uconv/native'
gmake[4]: *** [libs] Error 2
gmake[4]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-1.9_pre20070304/work/mozilla/intl/uconv'
gmake[3]: *** [libs] Error 2
gmake[3]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-1.9_pre20070304/work/mozilla/intl'
gmake[2]: *** [libs_tier_necko] Error 2
gmake[2]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-1.9_pre20070304/work/mozilla'
gmake[1]: *** [tier_necko] Error 2
gmake[1]: Leaving directory `/var/tmp/portage/net-libs/xulrunner-1.9_pre20070304/work/mozilla'
make: *** [default] Error 2


Reproducible: Always




sl007 ~ # gcc -v
Using built-in specs.
Target: i686-pc-linux-gnu
Configured with: /var/tmp/portage/sys-devel/gcc-4.1.2/work/gcc-4.1.2/configure --prefix=/usr --bindir=/usr/i686-pc-linux-gnu/gcc-bin/4.1.2 --includedir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include --datadir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2 --mandir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/man --infodir=/usr/share/gcc-data/i686-pc-linux-gnu/4.1.2/info --with-gxx-include-dir=/usr/lib/gcc/i686-pc-linux-gnu/4.1.2/include/g++-v4 --host=i686-pc-linux-gnu --build=i686-pc-linux-gnu --disable-altivec --enable-nls --without-included-gettext --with-system-zlib --disable-checking --disable-werror --enable-secureplt --disable-libunwind-exceptions --disable-multilib --disable-libmudflap --disable-libssp --disable-libgcj --enable-languages=c,c++ --enable-shared --enable-threads=posix --enable-__cxa_atexit --enable-clocale=gnu
Thread model: posix
gcc version 4.1.2 (Gentoo 4.1.2)
(Reporter)

Comment 1

11 years ago
Created attachment 257337 [details] [diff] [review]
mozilla-iconv-uconv-ns.patch

This patch prepends the namespace to the signal names.
(Reporter)

Comment 2

11 years ago
The first problem (kOnError_Signal errors) is because of #372076.

Second part seems to come from #342750
Duplicate of this bug: 380253
(Assignee)

Updated

11 years ago
Duplicate of this bug: 376141

Updated

11 years ago
Depends on: 342750

Updated

11 years ago
Assignee: nobody → smontagu
Status: UNCONFIRMED → NEW
Component: XULRunner → Internationalization
Ever confirmed: true
Product: Toolkit → Core
QA Contact: xulrunner → i18n
Version: unspecified → Trunk

Updated

11 years ago
Attachment #257337 - Flags: review?(smontagu)
(Assignee)

Comment 5

11 years ago
Comment on attachment 257337 [details] [diff] [review]
mozilla-iconv-uconv-ns.patch

per IRC discussion this patch is necessary but insufficient to fix the build errors.
Attachment #257337 - Flags: review?(smontagu) → review-
Created attachment 264348 [details] [diff] [review]
mozilla-iconv-uconv-ns.patch
(Assignee)

Updated

11 years ago
Attachment #264348 - Flags: review+
(Assignee)

Updated

11 years ago
Attachment #257337 - Attachment is obsolete: true

Comment 7

11 years ago
smontagu: so should the new patch be checked in? Does it need a separate sr?
(Assignee)

Comment 8

11 years ago
Checked in (sr not required).
(Assignee)

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
Why doesn't nsRefPtr work (at least once nsAutoPtr.h is #included)?
(Assignee)

Comment 10

11 years ago
With nsRefPtr the build fails with:
mozilla/intl/uconv/native/nsNativeUConvService.cpp:394: error: ‘nsISupports’ is an ambiguous base of ‘nsDerivedSafe<IConvAdaptor>’
You need to log in before you can comment on or make changes to this bug.