Downloading any file with the Download Manager does exactly nothing

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: tanis, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Whenever I download a file with Firefox's Download Manager, nothing is created in the destination folder and the Downloads window is empty. If I use any other download manager (like FlashGot) it works a charm.

Reproducible: Always

Steps to Reproduce:
1.Click on any downloadable URL
2.Select not to use a different download manager if you've got FlashGot or anything smilar installed
3.Click on Save and watch it doing exactly nothing
Actual Results:  
Nothing at all. No file created in the destination folder and nothing displayed in the download manager window

Expected Results:  
The file I'm downloading should appear in the destination folder sooner or later
Please try cleaning up your download manager or try deleting the downloads.rdf file: http://kb.mozillazine.org/Downloads.rdf
Before doing so you might want to attach the downloads.rdf file to this bug in case someone wants examine it.
(Reporter)

Comment 2

12 years ago
I'm not attaching the file as it contains personal information that I do not want to disclose. But I noticed that my file is actually 95k in size and truncated. 

The last entry looks like this:
  <RDF:Description RDF:about="C:\Games\World of Warcraft\Interface\AddOns\nurfeduiBC.zip"
                   NC:Name="nurfeduiBC.zip"
                   NC:Transferred="1KB of  1KB">
    <NC:URL RDF:resource="http://www.nurfedui.net/download.php?file=nurfeduiBC.zip"/>
    <NC:File RDF:resource="C:\Games\World of Warcraft\Interface\AddOns\nurfeduiBC.zip"/>
    <NC:DateStarted NC:parseType="Date">Wed Nov 01 10:32:14 ora solare Europa occidentale 2006 +203125</NC:DateStarted>
    <NC:DateEnded NC:parseType="Date">Wed Nov 01 10:32:14 ora solare Europa occidentale 2006 +203125</NC:DateEnded>
    <NC:DownloadState NC:parseType="Integer">1</NC:DownloadState>
    <NC:ProgressPercent NC:parseType="Integer">100</NC:ProgressPercent>
  </RDF:Description>
  <RDF:De


As you can see there's a piece of an opening tag and then nothing else. Is it possible that Firefox does no validation whatsoever of this file? 

I've deleted the downloads.rdf file and now everything works as expected.
-> works for me.

Resolving this as works for me , comment #2 reports that the problem was resolved after the downloads.rdf File was deleted
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
Version: unspecified → 2.0 Branch
(Assignee)

Updated

11 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.