Regression: attachment button isn't displayed on envelope/can't save attachment

VERIFIED FIXED in M17

Status

P3
major
VERIFIED FIXED
19 years ago
10 years ago

People

(Reporter: marina, Assigned: selmer)

Tracking

Trunk
All
Windows NT

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2+])

(Reporter)

Description

19 years ago
**** observed with 2000-04-26 build on IMAP *****
Steps to reproduce:
-open new mail composition window;
-fill out all field and click attach icon;
-attach a text file;
-send and get the message;
//note: there is nothing attached to your mail (it doesn happen with html 
attachment)
(Reporter)

Comment 1

19 years ago
Some additional comments: to see the attachment icon itself you have to reopen 
the message, first time you open it there is no attachment icon showing up.

Comment 2

19 years ago
Do you have any contents in the body of the message prior to sending (i.e. you 
type something in)?
Severity: normal → major
Keywords: nsbeta2
QA Contact: lchiang → pmock
(Reporter)

Comment 3

19 years ago
It doesn't look like it makes a difference: i've sent out 1)with no text in the 
body 2) with text in the body 3) with signature file attached 4) w/out signature 
file and in all those cases if it wasn't html file i didn't see any attachment 
showing up.

Comment 4

19 years ago
I was able to reproduce this problem.  It appears that the attachment icon on 
the envelope is missing or not being rendered.  If I view my mail message that 
was sent from 5.0 in 4.7, the attachment is present and can be saved.

I tried to resize the envelope but with no results.

Changing summary from
 Regression: non-html attachment coming up empty
  to:
 Regression: attachment button isn't displayed on envelope/can't save 
attachment.

This problem occurs on all of today builds:
 win32 commercial seamonkey build 00042609-m16 installed on Dell P500, Win98
 macos mozilla seamonkey build 00042611-m16 installed on G3/400, MacOS 9
 linux commercial seamonkey build 00042608-m16 installed on P200, RedHat 6.1
Hardware: PC → All
Summary: Regression: non-html attachment coming up empty → Regression: attachment button isn't displayed on envelope/can't save attachment

Comment 5

19 years ago
oh, I should have realized this.   We had a bug on this and it was fixed so this 
is a regression.  http://bugzilla.mozilla.org/show_bug.cgi?id=34379

Comment 6

19 years ago
Putting on [nsbeta2+] radar. 
Whiteboard: [nsbeta2+]
(Assignee)

Comment 7

19 years ago
Target M17.
Target Milestone: --- → M17

Comment 8

19 years ago
I fixed this last week I didn't know selmer had a bug on it =). Marking as fixed.
Status: NEW → RESOLVED
Last Resolved: 19 years ago
Resolution: --- → FIXED

Comment 9

19 years ago
Verified on win32 and macos using the following builds
 win32 commercial seamonkey build 00051609-m16 installed on Dell P500, Win98
 macos commercial seamonkey build 00051609-m16 installed on G3/400, MacOS 9.04

I've not verified this on linux yet.  Will do soon.

Comment 10

19 years ago
Verified on linux using the following build:
 linux commercial seamonkey build 2000-051608-m16.

Verified as fixed.
Status: RESOLVED → VERIFIED

Comment 11

19 years ago
fyi logged [PP] bug 39654 for linux because save as dialog fails to come up.
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.