Events off by 1 hour (Daylight Savings Time)

RESOLVED WORKSFORME

Status

Calendar
General
RESOLVED WORKSFORME
11 years ago
11 years ago

People

(Reporter: Thomas Blue, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006

Though Bug ID 363121 seems to be listed as resolved, entering an event today (05 March 2007) on a date after daylight savings time change (27 March 2007) results in the event time appearing as an hour earlier than as entered. (I have checked my time settings and such is correct. I work with lots of environmental monitoring equipment and high-accuracy - survey grade - GPS equipment, all of which are dependent upon temporal data and time synchronization, so I'm sure of my time settings. - Thanks!

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
What is your OS-timezone and your SB-timezone so we can try to reproduce? Also, can you export the event to an ics and post it (so including the timezone-data and the event-data?

Comment 2

11 years ago
There were several bugs resolved in 0.3.1 which might destroy timezonedata (bug 369014 bug 369270 bug 357481) so it's important to be able to reproduce your bug as with the litmus-testcases no blocking bugs were found. Please also include your SB-build# and/or your lightning build#. Do lightning and sunbird behave the same?
(Reporter)

Comment 3

11 years ago
I'm not using Lightning, just Sunbird.

My build is: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20061006

I am running WindowsXP (unfortunately) and my OS time zone settings are USEST (GMT-5) with automatic daylight savings time adjustment.

Comment 4

11 years ago
I suggest first upgrading to sunbird 0.3.1, you're running 0.3 as far as I can see from your version... Don't know where something went wrong in your upgrade-process...
Thomas,

Sunbird 0.3.1 was released recently that includes the DST timezone changes:
http://www.mozilla.org/projects/calendar/releases/sunbird0.3.1.html

Comment 6

11 years ago
Okay, I don't know how to get the Lightning team to act on this; I'm currently using Lightning and it's still busted. Any word on when a new build might include this fix? Seems pretty critical.

Comment 7

11 years ago
jstrachman: please post your version-information, OS-timezone and lightning-timezone.... I think Thomas's problem was solved by installing teh correct upgrade...

Comment 8

11 years ago
Happens to me with both lightning 0.3.1/TB1.5.0.10 (on XPp) and sunbird 0.3.1 (on Win2k).  Atlantic time zone (GMT-4).  Events entered to occur both before and after the DST change appear to be affected, i.e. an event entered at 9:00AM will appear in the calendar at 10:00AM.  If you edit the event it shows up back at 9:00 in the editor but is always displayed in the calendar as 10:00.  If I flip my clock ahead 1 week (past the DST change) and enter an event it has the opposite behaviour, i.e. an event entered for 9:00AM shows up in the calendar at 8:00AM.

Just noticed comment #14 of bug 363121.  Fixing *lightning's* timezone to match the OS timezone (as suggested in the sunbird release notes) indeed fixes the display problem.   Same calendar still displays wrong in Sunbird, even though the timezone is set correctly there...

Comment 9

11 years ago
Yes, I was running 0.3; I updated to 0.3.1 which works correctly now.
(In reply to comment #8)
> Happens to me with both lightning 0.3.1/TB1.5.0.10 (on XPp) and sunbird 0.3.1
> (on Win2k).
> [...]
> Just noticed comment #14 of bug 363121.  Fixing *lightning's* timezone to 
> match the OS timezone (as suggested in the sunbird release notes) indeed 
> fixes the display problem.   Same calendar still displays wrong in Sunbird, 
> even though the timezone is set correctly there...

This is probably Microsoft's fault and not ours, since MS does not offer a timezone patch for Windows 2000, but only for XP and Vista. Please see http://support.microsoft.com/kb/914387 on how to manually fix your operating system seetings.

Comment 11

11 years ago
Marking as WFM, only problem remaining is the win2k-OS, which can't be fixed by us...
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.