If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

The link "Next" not diplaying the Test Plan numbers in Sequential order.

RESOLVED FIXED

Status

Testopia
Test Plans
RESOLVED FIXED
11 years ago
11 years ago

People

(Reporter: Vijaya, Assigned: Greg Hendricks)

Tracking

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows 98)
Build Identifier: Internet Explorer 6.0

When you click on the link "Next" which is under the displayed "TestPlan Id :Name" , is not displaying the sequential order of the TestPlan Ids.



Reproducible: Always

Steps to Reproduce:
Steps to reproduce that bug:-
1. Go to http://bugz.deanza.edu/bugzilla_testopia/
2. Enter your Login & Password and click on the "Login" button.
3. Goto "Testopia Search" and click on "Find Test Plans"
4. Click on "Submit" button which is on the bottom.
5. Click on the link "All" which is inside the frame (just above the 
   heading "Update Selected Test Plans").
6. Click on the first Test Plan which is "Micellaneous testing"
7. So now you see the following :
   "Test Plan 2: Miscellaneous testing
   Plan List: <<First Prev   (1 of 37)   Next > Last >>" 
  
   So keep clicking the next button to see which "TestPlans" are being Diplayed.
Actual Results:  
It is displaying the TestPlan Id along with the TestPlan name for 

2, 3, 4, 5, 6, 8, 9, 10, 11, 12, 13, 14, 15, 16, 17, 18, 19, 20, 21, 33, 23,
24, 25, 26, 27, 28, 29, 30, 31, 32, 34, 35, 41, 38, 39, 40, 42

Expected Results:  
Since it is assigning a sequential number for the test plans created, it has to display the TestPlans in same order only (starting from 1...end of the TestPlans).
(Reporter)

Comment 1

11 years ago
It is omitting some testplans like 1, 7, 22, 33, 36, 37 out of which 22 and 36 do not exist because they were deleted. 
(Reporter)

Updated

11 years ago
Severity: major → critical
(Assignee)

Comment 2

11 years ago
The 'next' is referring to the next plan that was returned in your search results. If your search criteria did not include certain plans, then it will not be available in the list. Was plan 1, 7,33 etc returned in the list to begin with when you ran your search?

If so this is working as designed. 
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INVALID
(Reporter)

Comment 3

11 years ago
Worked out fine when i changed the "Unarchive" to "archive" and sorted the testplans based on the date created. Then it listed all the testplans in a sequential order skipping those testplans which were deleted.
Resolution: INVALID → FIXED
(Reporter)

Updated

11 years ago
Severity: critical → normal
You need to log in before you can comment on or make changes to this bug.