Copy/Cut menu items initially disabled; focus/controller issue

VERIFIED WORKSFORME

Status

()

Core
Editor
P1
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: Eli Goldberg, Assigned: saari (gone))

Tracking

({pp, regression})

Trunk
x86
Windows NT
pp, regression
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
* TITLE/SUMMARY
Copy/Cut menu items initially disabled

<As noted by shrirang from smoke-testing. Can't find a bug for it in XP Toolkit: 
Menus, so...)

* STEPS TO REPRODUCE
0) Launch Seamonkey
1) Open a browser window
2) Select the contents of the URL bar
3) Open the Edit menu

* RESULT
 - What happened

"Cut" and "Copy" are not enabled; only "Paste" is enabled. The keyboard 
shortcuts, however, do work.

It gets more busted from here; I'll add more soon.

 - What was expected 

The "Cut" and "Copy" menu items should both be enabled. "Paste" should be 
enabled, too, if the copy buffer contains content.

* REGRESSION

 - Occurs On
        Win32 Seamonkey (4.26.00 AM optimized Mozilla build [NT 4, Service Pack 
5])

 - Doesn't Occur On
        Mac OS Seamonkey (4.26.00 AM optimized Mozilla build)		
        Linux Seamonkey (4.26.00 AM optimized Netscape build)




* CONFIGURATIONS TESTED

- [Mac] Beige Power Mac G3 (266 MHz PowerPC 750), 96 MB RAM (VM on; 1 MB of VM 
used), 1024x768 (Thousands of Colors), Mac OS 8.6

- [Win32] Vectra VL (233 MHz P2), 96 MB RAM, 800x600 (True Color), NT 4.0 SP5.

- [Linux] Vectra VL (266 MHz P2), 96 MB RAM. Red Hat Linux 6.0 (GNOME).
(Reporter)

Comment 1

18 years ago
More fun:

After steps 1-3, close the Edit menu, press the 'Delete' key, and *then* open the 
Edit menu. 

Cut/Copy/Paste will not only be disabled, but if you subsequently enter text into 
the URL field, select it, and open the Edit menu, those menu items will remain 
disabled.
(Reporter)

Comment 2

18 years ago
Shrirang: are there other related issues that you or the #smoketesters found that 
you'd care to mention, or like me to look into? thanks!
i don't think this belongs in XPMenus (correct me if am wrong)...sounds like
something for the editor group.
Assignee: pinkerton → beppe
Component: XP Toolkit/Widgets: Menus → Editor
Keywords: pp, regression
QA Contact: sairuh → sujay

Comment 4

18 years ago
I'm pretty sure this is a focus issue. Sometimes, in debug builds, you hit 
assertions in the docviewer controller, because it's being asked about commands 
that should be going to the editor controller.
Assignee: beppe → saari
Summary: Copy/Cut menu items initially disabled → Copy/Cut menu items initially disabled; focus/controller issue
(Reporter)

Comment 5

18 years ago
QA Assigning to self.
QA Contact: sujay → elig

Comment 6

18 years ago
so, if it is a focus issue, shouldn't that go to hyatt?

Comment 7

18 years ago
qa: sujay
QA Contact: elig → sujay

Comment 8

18 years ago
adding myself to cc: 
Occurs in mail subject fields, etc.
(Reporter)

Comment 9

18 years ago
This is a cut/copy-specific issue. QA Assigning to myself for the third time.
QA Contact: sujay → elig

Comment 10

18 years ago
*** Bug 37282 has been marked as a duplicate of this bug. ***

Comment 11

18 years ago
*** Bug 37260 has been marked as a duplicate of this bug. ***

Comment 12

18 years ago
bug 37260  Keyboard ctrl-c, shift-insert don't work (marked as dup).  
bug 37327  Crashes mac

dup or un-dup as necessary as the cause/causes are found.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M16
(Assignee)

Comment 13

18 years ago
Why, oh why is this only broken on Windows?!?

Excuse me while I beat my head against a wall.
(Assignee)

Updated

18 years ago
Priority: P3 → P1
*** Bug 37327 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 15

18 years ago
Well, I just tried this several times with tonight's build on NT and it seems to
be working fine. I'll mark worksforme unless someone else is still seeing this
not work or has more information on how to reproduce it.

In fact, the more I play with it, it looks like this is working better than ever.

Comment 16

18 years ago
*** Bug 39433 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
Propagating nsbeta2 nomination from 39433.
Keywords: nsbeta2

Comment 18

18 years ago
*** Bug 39516 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 19

18 years ago
Simon, can you still repro this? It works for me
(Assignee)

Comment 20

18 years ago
Tried again, still works. Marking worksforme
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 21

18 years ago
marking Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.