Firefox can't find the server at www.%1.com. (CDROM Autorun Issue w/ Firefox 2.0)

RESOLVED INCOMPLETE

Status

()

Firefox
General
RESOLVED INCOMPLETE
11 years ago
8 years ago

People

(Reporter: Joe Skazinski, Unassigned)

Tracking

2.0 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

When inserting a CDROM Firefox is automatically launched but the index.htm on the disk is not displayed. Instead, Firefox displays an error dialog with the message:
"Firefox can't find the server at www.%1.com."

This CD worked fine with my previous version of Firefox, which I believe was 1.5, but I was using the latest available prior to 2.0.xx

Reproducible: Always

Steps to Reproduce:
1. Insert CDROM
2.
3.
Actual Results:  
Firefox display an HTML page titled "Problem loading page" and the HTML page displayed shows:
Server not found
Firefox can't find the server at www.%1.com.
(Three bullets w/ text)
Try Again


Expected Results:  
Firefox should display the HTML page.

Tested w/ IE 6.0 and it worked fine.

The CDROM's root folder looks like this:
autorun.inf
cdstart.exe
index.htm
README.txt

The autorun.inf contains:
[AUTORUN]
open=cdstart.exe index.htm

I didn't create cdstart.exe so I don't know how it was created but can send you it if desired.
Assignee: nobody → marcia
Component: General → Mozilla Store
Product: Firefox → mozilla.org
QA Contact: general → marcia
Version: unspecified → other
Joe: When we tested the Firefox 2.0 CD on Win XP (I assume you are talking about the latest version of the Firefox CD and not an older version) we didn't see the issues you are describing. The CD should just launch the auto-run when you put it in the drive and you should get the executable file.
(Reporter)

Comment 2

11 years ago
Hi Marcia. Thanks for the response, but my issue is different. I already have 2.0 installed and it is working great. The problem is when I insert a Kozio CDROM, which hasn't changed and worked with Firefox 1.5. It appears that when the CDROM causes a Windows XP event to launch my default browser, that is when Firefoc fails. When I change my default browser to IE 6, all works fine. Plus, when I use FireFox 2.0 to open a the index.htm on the CDROM, it works fine. Just the autorun fails. Thank you, Joe
Assignee: marcia → nobody
Component: Mozilla Store → General
Product: mozilla.org → Firefox
QA Contact: marcia → general
Version: other → 2.0 Branch
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.