Crash on Firefox quit(2)

VERIFIED DUPLICATE of bug 353716

Status

--
critical
VERIFIED DUPLICATE of bug 353716
12 years ago
9 years ago

People

(Reporter: n.sanjay.narasimman, Assigned: jaas)

Tracking

1.8 Branch
PowerPC
Mac OS X

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Firefox crashed without Talkback when I quit.

P.S: I didn't search enough for a duplicate.

Reproducible: Didn't try

Steps to Reproduce:
1.
2.
3.
Actual Results:  
I got a crash with the Apple Crash reporter.

Expected Results:  
No crash.
Even if it crashes Talkback should launch on Firefox open.

First few lines of crash report:
Version: 2.0.0.2 (2.0.0.2)

PID:    474
Thread: 0

Exception:  EXC_BAD_ACCESS (0x0001)
Codes:      KERN_INVALID_ADDRESS (0x0001) at 0xfffe5171

Thread 0 Crashed:
0   org.mozilla.firefox 	0x005778bc nsMacEventHandler::ConvertOSEventToMouseEvent(EventRecord&, nsMouseEvent&, unsigned) + 284
1   org.mozilla.firefox 	0x00578046 nsMacEventHandler::HandleMouseMoveEvent(EventRecord&) + 280
2   org.mozilla.firefox 	0x00245546 nsMacWindow::DispatchEvent(void*, int*) + 50
3   org.mozilla.firefox 	0x00571b2e nsMacMessagePump::DispatchOSEventToRaptor(EventRecord&, OpaqueWindowPtr*) + 76
4   org.mozilla.firefox 	0x00571b87 nsMacMessagePump::DoMouseMove(EventRecord&) + 69
5   org.mozilla.firefox 	0x005721e0 nsMacMessagePump::WNETransitionEventHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 40
6   com.apple.HIToolbox 	0x92dcc7eb DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 1093
7   com.apple.HIToolbox 	0x92dcbe90 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
8   com.apple.HIToolbox 	0x92dd30f0 SendEventToEventTarget + 56
9   com.apple.HIToolbox 	0x92dd3b12 ToolboxEventDispatcherHandler(OpaqueEventHandlerCallRef*, OpaqueEventRef*, void*) + 2586
10  com.apple.HIToolbox 	0x92dccba2 DispatchEventToHandlers(EventTargetRec*, OpaqueEventRef*, HandlerCallRec*) + 2044
11  com.apple.HIToolbox 	0x92dcbe90 SendEventToEventTargetInternal(OpaqueEventRef*, OpaqueEventTargetRef*, HandlerCallRec*) + 304
12  com.apple.HIToolbox 	0x92dd30f0 SendEventToEventTarget + 56
13  com.apple.HIToolbox 	0x92e16d8f ToolboxEventDispatcher + 81
14  com.apple.HIToolbox 	0x92e15783 RunApplicationEventLoop + 165
15  org.mozilla.firefox 	0x00240d7f nsAppShell::Run() + 39
16  org.mozilla.firefox 	0x002d94ba nsAppStartup::Run() + 50
17  org.mozilla.firefox 	0x00005db9 XRE_main + 6305
18  org.mozilla.firefox 	0x00002818 main + 32
19  org.mozilla.firefox 	0x0000279e start + 270
20  org.mozilla.firefox 	0x000026b9 start + 41
(Reporter)

Comment 1

12 years ago
Created attachment 257577 [details]
Crash log for "Crash on quit (2)
Assignee: nobody → joshmoz
Component: OS Integration → Widget: Mac
Product: Firefox → Core
QA Contact: os.integration → mac
Version: unspecified → 1.8 Branch

Comment 2

12 years ago
I believe that this bug is a duplicate of bug 353716.
Indeed.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 353716

Updated

12 years ago
Duplicate of this bug: 364918

Updated

12 years ago
Status: RESOLVED → VERIFIED

Updated

9 years ago
Component: Widget: Mac → Widget: Mac
Product: Core → Core Graveyard
You need to log in before you can comment on or make changes to this bug.