Closed Bug 372993 Opened 13 years ago Closed 13 years ago

Can't switch off proxy in connection settings

Categories

(Calendar :: Sunbird Only, defect)

defect
Not set

Tracking

(Not tracked)

VERIFIED FIXED

People

(Reporter: peterswegberg, Assigned: ssitter)

Details

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-DE; rv:1.8.1.3pre) Gecko/20070305 Calendar/0.5pre

I use a laptop in my office (with a proxy) and at home (without a proxy. I tried to change the connection settings from "Manual proxy configuration" to "direct connection to the internet". I can select the radio-button, but nothing changes. If i close the form and re-enter it, the radio-button "Manual proxy configuration" is selected again. 

Reproducible: Always

Steps to Reproduce:
1. Go to Options-Connection Settings-
2. Try to change the radio-buttons
3.



I tried to solve the problem on two systems (one with a new profile)!
Confirming on Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.3pre) Gecko/20070306 Calendar/0.5pre

I get the following error in the error console:

Error: syntax error
Source File: chrome://calendar/content/preferences/connection.js
Line: 172, Column: 3
Source Code:
  },
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Can´t switch off proxy in connection settings → Can't switch off proxy in connection settings
I'm getting it on Mac too. 

Note that because of the preprocessing, the line number is deceiving.  Line 172 is actually the end of the doAutoconfigURLFixup function.
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → Trunk
Attached patch rev0 - patchSplinter Review
The preprocessor removed the closing bracket in case of MOZILLA_1_8_BRANCH leading to the syntax error, this patch fixes this.
Assignee: nobody → ssitter
Status: NEW → ASSIGNED
Attachment #257865 - Flags: first-review?(lilmatt)
Comment on attachment 257865 [details] [diff] [review]
rev0 - patch

Nice catch.

r=lilmatt
Attachment #257865 - Flags: first-review?(lilmatt) → first-review+
Patch checked in on MOZILLA_1_8_BRANCH and trunk.

-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 13 years ago
Resolution: --- → FIXED
The problem is solved. Thanks for your quick help.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.