Duplicate messages are created in local folders after being moved by filter (2 part bug)

RESOLVED DUPLICATE of bug 370277

Status

SeaMonkey
MailNews: Message Display
--
major
RESOLVED DUPLICATE of bug 370277
11 years ago
11 years ago

People

(Reporter: Joshua, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070222 SeaMonkey/1.1.1

After upgrading to SeaMonkey 1.1.1 I noticed that all my filtered email, each morning is being duplicated, the email IDs are the same in the header, so its SeaMonkey that is duplicating them.

After an hour of testing I have found there is actually 2 bugs here.

This is to do with filters duplicating my messages. I have found that when I start the app, every email message that matches a filter I get twice in my local folders.

Using the steps below, I have been able to reproduce this every time. But you must have more then 2 messages that match any number of filters. This doesn't happen if you only have ONE email for collection.

I have also found a work around for this bug, which opens up another bug, which I will raise another bug report for.

If you untick the "Check for new messages at startup" in the server settings, you will no longer get duplicate emails from the filters. (But on startup SeaMonkey still checks for email.....)

Reproducible: Always

Steps to Reproduce:
1. Create a filter to move a message with subject line "test for dup mess" to a local folder
2. Make sure that "Check for new messages at startup" is selected in in your server settings
3. Shutdown SeaMonkey
4. Send yourself two emails, one with "test for dup mess #1" and "test for dup mess #2" in the subject line from another user or client
5. Startup SeaMonkey and open your Mail and Newsgroups window
6. Look in the local folder for the two email you sent yourself, and you will see each email is duplicated
Actual Results:  
Each email that was send has two copies in the local folder

Expected Results:  
Should only have one email, not two.

A workaround for this bug is to
- un-tick the "Check for new messages at startup"

Rerun the above steps and you will see that there is no more duplicate emails that are filtered.


about:buildconfig

Build platform
target
i586-pc-msvc

Build tools
Compiler 	Version 	Compiler flags
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TC -nologo -W3 -Gy -Fd$(PDBFILE)
$(CYGWIN_WRAPPER) cl 	12.00.8804 	-TP -nologo -W3 -Gy -Fd$(PDBFILE)

Configure arguments
--enable-application=suite --disable-tests --without-system-jpg --without-system-zlib --enable-extensions=default,tasks --enable-crypto --disable-debug --enable-optimize --enable-svg --enable-canvas
(Reporter)

Comment 1

11 years ago
I should have also said that I am using IMAP as my server settings.

Comment 2

11 years ago
Duplicate Duplicate messages bug :-) please try a newer 2.0 beta 2 nightly build from here: ftp://ftp.mozilla.org/pub/mozilla.org/thunderbird/nightly/latest-mozilla1.8
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 370277
You need to log in before you can comment on or make changes to this bug.