If there is no existing profile at startup, ask the user for location of the profile

VERIFIED WONTFIX

Status

()

Firefox
Installer
VERIFIED WONTFIX
12 years ago
12 years ago

People

(Reporter: Tushar T, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Whenever firefox is installed for the first time on a system, and if there is no existing profile that firefox can use, instead of creating a default profile in a "standard" location, the user should be asked to create a profile in a location that they want. Perhaps an option should be provided to allow the user to create a default profile and bypass the profile creation dialogs to make it easier for users to create a profile in the default directory.

Some users have their profiles saved in alternate locations to make it easier for backing it up. The current way to achieve this is to exit firefox, start the profile manager (for which there is no UI!), delete the already created profile and then create a new profile in a new location.

I agree that the UI should not be made complex for general users but that should not be at the cost of making "advanced users" jump through hoops to customize it.

Reproducible: Always

Comment 1

12 years ago
Advanced users can use the -profile or -CreateProfile commandline flags to specify the location of a profile. We do not want to expose any UI for this, because research has shown that the vast majority of users don't know what the question could mean anyway.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
(Reporter)

Comment 2

12 years ago
Ah! The dumb user argument!!!
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.