Delay in displaying messages selected with the keyboard

RESOLVED DUPLICATE of bug 242791

Status

--
major
RESOLVED DUPLICATE of bug 242791
12 years ago
11 years ago

People

(Reporter: paul, Assigned: mscott)

Tracking

x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-GB; rv:1.8.0.10) Gecko/20070216 Firefox/1.5.0.10
Build Identifier: version 2 beta 2 (20070116)

Messages selected with they keyboard are not displayed for around 1 second in the preview pane. Messages selected with the mouse are displayed instantly.

Reproducible: Always

Steps to Reproduce:
1. Go to a folder with multiple messages
2. Select the first message
3. Press the down arrow key to select the next message
Actual Results:  
The preview pane will take a few moments to update and display the currently selected message.

Expected Results:  
The preview pane should update instantly, as it does when messages are selected with the mouse.

Pressing the delete key to delete a message updates the preview pane instantly. It only seems to be the arrow keys and page up/down keys that are affected.

This behaviour might be by design, to allow fast movement of the selection indicator via the keyboard without the preview pane slowing things down. However, at the very least there should be a parameter in about:config to set the amount of delay, or disable it.

The current delay severly slows down navigation and operation of Thunderbird via the keyboard.
(Reporter)

Updated

12 years ago
Version: unspecified → 1.5
(Reporter)

Comment 1

12 years ago
This problem can be fixed by installing the userChrome add-on, then adding the following to userChrome.js:

document.getElementById("threadTree")
  .setAttribute("_selectDelay", "0")

However, there should still, IMHO, be an about:config value. Plus, the default delay of 500ms is far too high. 100ms should be enough, 200 at the most. 100ms works well on an old 800MHz Compaq laptop with Windows 2000 and 128MB RAM.

Comment 2

11 years ago
version 3.0a1pre (2008040302)
Windows XP SP2

It can be reproduced. Clicking and selecting with mouse just don't produce the same effects, since keyboard-commanded switch is delayed.

Updated

11 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 242791
You need to log in before you can comment on or make changes to this bug.