Apply button needed in addition to "Ok" & "Cancel"

RESOLVED INCOMPLETE

Status

()

RESOLVED INCOMPLETE
12 years ago
8 years ago

People

(Reporter: mozilla, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [CLOSEME 2010-11-15])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

For some reason, the "Apply" button was not implemented in many dialogs.  This is almost an "accessibility" issue, though at least, a "usability" issue.

Many times I want to change a parameter and "apply" the parameter to see the effect -- but I don't want to close the options menu.  Currently this ability seems to be broken/missing.

As a specific example relating to accessibility/usability, I wanted to look for fonts that were more readable.  Everytime I change the font, however, I have to press "Ok", which makes the font box go away.  I then have to goto Tools, find Options again (usually buried near bottom), and re-open.  Then I can re-position to the font box, and type in the first few chars of the next font -- if I knew the name (font list is long, scrolls off bottom).

All this is busy-work, requiring lots of mousing, clicking and typing unknown font names all to be able to go through fonts and see which looks best for a given page, size and language.

I've never understood the desire to force a user to dismiss an option dialog in order to see its affect.

It's very annoying -- and, at times, painful (if RSI acting up), and is always a lengthy process, since I have to bring the window back up with each font I try.
I'd wish it would be considered "serious", but I know it's an RFE, which by definition means it isn't "serious", and by inference on the list, has an importance *below* "trivial" :-(.

Anyway..."Apply"!  If people have major upsets around this, add a config var
Display:Noshowapply:0/1 or something similar.



Reproducible: Always

Steps to Reproduce:
1. Goto font selection and desire to try multiple fonts.  Pick one.
2. Now pick next font on list.  
3.
Actual Results:  
The font entry box has disappeared.

Expected Results:  
Desired results:
Configuration option settings stay until I am done, but I am allowed to apply settings without dismissing the options box.
Component: General → Preferences
QA Contact: general → preferences
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 200159
(Reporter)

Comment 2

12 years ago
This bug has nothing to do with 200159 -- this isn't a modal issue, in fact, 
in bug 200159, the reasoning that IE explorer implemented modal dialoges was used as an excuse for breaking FF in the same way.  In this case, however, IE HAS an Apply dialog that allows you to apply changes and see their effect *without* closing the settings dialog.  

Using the logic of "we do something this way because that's the windows way", would imply, in this case, that this is a bug, not an RFE, as the "Apply" button is missing in FF while it is present in IE.

Accordingly I'll up this to the status of a "bug", as IE seems to be getting used as some "standard" (though why we'd use MS as a standard for FF, is beyond me)...

So -- clarification.  Am filing this as a bug because IE has an Apply button and that Firefox is missing, and, by the logic used to justify modality in bug 200159, doing it the windows way seems to be some [?!?] standard...(oi vey!)...
Severity: enhancement → normal
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---

Comment 3

12 years ago
I also recommend an "apply" button, as I have to work out proper fonts for several systems. 
This bug was reported using Firefox 3.0 or older, which is no longer supported. The bug has also not been changed in over 500 days and is still in UNCO.
Reporter, please retest this bug in Firefox 3.6.10 or later using a fresh profile, http://support.mozilla.com/en-US/kb/managing+profiles. If you still see this problem, please update the bug. If you no longer see the bug, please set the resolution to RESOLVED, WORKSFORME.

This is a mass search of unconfirmed bugs that have no activity on them, so if you feel a bug was marked in error, just remove the CLOSEME comment in the whiteboard within the next month.
Whiteboard: [CLOSEME 2010-11-15]
No reply, INCOMPLETE. Please retest with Firefox 3.6.12 or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago8 years ago
Resolution: --- → INCOMPLETE
You need to log in before you can comment on or make changes to this bug.