3pane, Account Selected: Go menu should match spec

VERIFIED INVALID

Status

SeaMonkey
MailNews: Message Display
P3
normal
VERIFIED INVALID
18 years ago
14 years ago

People

(Reporter: Ninoschka Baca, Assigned: scottputterman)

Tracking

({polish})

Trunk
Future
All
Windows 95
polish

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Build 2000-04-21-08M16: NT4, Linux 6.0
Build 2000-04-21-15M16: Mac 9.0

Overview: In the 3pane, select the Account level, select the Go menu and the 
items listed should match the spec.

1. Add
a) "Mail Start Page" should appear after "Forward"
b) Next submenu
- "Folder" should appear after "Unread Thread"
- "Unread Folder" should appear after "Folder"

2. Change
a) .First Unread Message: Remove the dot
b) .First Flagged Message: Remove the dot
c) .Back: Remove the dot
d) .Forward: Remove the dot

3. Disable: jglick what are your views on this?
a) When the first account is selected then the "Previous" menu items should be 
disabled.
(Reporter)

Updated

18 years ago
Keywords: ui
QA Contact: lchiang → nbaca

Comment 1

18 years ago
>3. Disable: jglick what are your views on this?

I'd recommend disabling all the menu items.  This is all stuff for navigating 
among messages.
(Assignee)

Updated

18 years ago
Status: NEW → ASSIGNED
Target Milestone: --- → M18
(Reporter)

Comment 2

18 years ago
Item 1b update:
Go|Next|Folder and Go|Next|Unread Folder should not be added (due to bug# 17801)

Item 2 Update:
Instead of Change, the following items should be Removed:
a. First Unread Message (due to bug# 16983)
b. First Flagged Message (due to bug# 16979)
c. Back (due to bug# 16975)
d. Forward (due to bug# 16976)

Comment 3

18 years ago
Item 2 Update:
Instead of Change, the following items should be Removed:
a. First Unread Message (due to bug# 16983)
   Per Lisa's request, I have wriiten Bug 45195 to remove menu item
b. First Flagged Message (due to bug# 16979)
   See Bug 45201 to remove menu item
c. Back (due to bug# 16975)
   See bug 45203 to remove menu item
d. Forward (due to bug# 16976)
   See bug 45204 to remove menu item
(Assignee)

Comment 4

18 years ago
nominating as nsbeta3 polish
Keywords: nsbeta3, polish

Comment 5

18 years ago
per mail triage:  remove nsbeta3 nomination and move to future milestone.  For 
the short term, we will combine items here into three bugs (in 3pane) to address 
for nsbetat3:  1. delete, change text, move menuitems;  2. enable/disable and 
text changes on context (dynamic);  3.  accelerator keys to work.

When this bug gets revisited after the first release, we'll need to see what 
items remaining that need to be addressed.
Keywords: nsbeta3
Target Milestone: M18 → Future
(Reporter)

Comment 6

17 years ago
Marking Invalid.

It is a dupe of bug# 75622 which is basically a summary bug (it covers 3pane: 
all menu items, mnemonic and accelerator issues in the same bug). The reason for 
marking it Invalid is because I don't want to create more noise in the summary 
bug. Please go to bug# 75622 for more recent status.
Status: ASSIGNED → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → INVALID
(Reporter)

Comment 7

17 years ago
Verified
Status: RESOLVED → VERIFIED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.