If you think a bug might affect users in the 57 release, please set the correct tracking and status flags for Release Management.

addBinding malformed URI

RESOLVED DUPLICATE of bug 369216

Status

()

Core
XBL
--
major
RESOLVED DUPLICATE of bug 369216
11 years ago
11 years ago

People

(Reporter: marc dassonneville, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; fr; rv:1.8.1.2) Gecko/20070219 Firefox/2.0.0.2

Firefox Crash when using document.addBinding with malformed URI.

document.addBinding(node, "chrome://yourapps/content/foo/bar/chrome://yourapps/content/foo/bar/foo.xbl");

crash firefox 2.0.0.2

Maybe this bug is related to #369216
(https://bugzilla.mozilla.org/show_bug.cgi?id=369216)

can't reproduce this on the nightly build.



Reproducible: Always

Steps to Reproduce:
1. try a malformed addBinding() in the chrome
2.
3.
Actual Results:  
crash
It's related like a duplicate... ;)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 369216
You need to log in before you can comment on or make changes to this bug.