Drop menus don't work in Yahoo beta mail.

RESOLVED DUPLICATE of bug 365987

Status

Camino Graveyard
General
RESOLVED DUPLICATE of bug 365987
11 years ago
11 years ago

People

(Reporter: Jeremy Marusek, Unassigned)

Tracking

Details

(Reporter)

Description

11 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070224 Camino/1.1b+
Build Identifier: Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en; rv:1.8.1.2pre) Gecko/20070224 Camino/1.1b+

I'm using Yahoo's beta mail and certain drop menus don't work. I have 4 email accounts and when I go to compose the drop menu where I select which account to send from will appear but won't let me select a different email account. Also, I can't just click on check all mail. I have to click and hold down the button and then release the click on each account.

Reproducible: Always

Steps to Reproduce:
1.
2.
3.

Comment 1

11 years ago
Does spoofing as Firefox using

http://pimpmycamino.com/parts/user-agent

improve things at all?

Updated

11 years ago
Component: Toolbars & Menus → Page Layout
QA Contact: toolbars → page.layout
Summary: Drop menu's don't work in Yahoo beta mail. → Drop menus don't work in Yahoo beta mail.
Jeremy, can you please respond to comment 1?
Whiteboard: [CLOSEME - 4/1]
Closing WFM due to lack of updates.  If the problem still occurs in a recent official nightly and you can supply the requested additional information, you may reopen this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → WORKSFORME

Comment 4

11 years ago
Re-opening; we've been getting more reports of this, so I made an account and played around with it for a little while. The menus will open, but they just close without action when you click on an item.
- Middle-clicking instead of left-clicking does work for at least the help menu (but of course opens the link in another tab/window)
- They work in Firefox 2
- They don't work in Camino (branch or trunk) spoofing as Firefox
- They don't work in Minefield

So it appears to be something to do with the Cocoa widget mouse event system. I noticed that in FF2, nothing happens on the mousedown on a menu item, whereas in Camino/Minefield the menu is dismissed immediately on mousedown (which explains why nothing then happens; the link trigger would be on mouseup, but by then it's gone). The question is whether we are doing something wrong, or they are making a bad assumption in their JS.
Status: RESOLVED → UNCONFIRMED
Component: Page Layout → General
Resolution: WORKSFORME → ---
Whiteboard: [CLOSEME - 4/1]

Updated

11 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Duplicate of this bug: 379984

Comment 6

11 years ago
Apologies for filing the duplicate. I had searched, but for some reason missed it. Had also asked a couple of times in mozillazine forums if it had already been filed and got no response.

Comment 7

11 years ago
The issue seems to be gone; most likely they changed their menu implementation. Closing WFM, since without a test case we'll never know just what it is that they were doing (and we have other bugs that may cover the same underlying problem anyway).
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME

Comment 8

11 years ago
Actually, I take that back. Menus that end up over an ad section still don't work, which makes this a dup of 365987.
Resolution: WORKSFORME → DUPLICATE
Duplicate of bug: 365987
You need to log in before you can comment on or make changes to this bug.