Bogus Vista Keys from 1.5.0.10 Shim Need Cleaned Up When Installing Thunderbird

RESOLVED FIXED

Status

Thunderbird
General
RESOLVED FIXED
12 years ago
10 years ago

People

(Reporter: Scott MacGregor, Assigned: Scott MacGregor)

Tracking

({verified1.8.1.3})

x86
Windows XP
verified1.8.1.3
Bug Flags:
blocking-thunderbird2 +

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Assignee)

Description

12 years ago
Marcia gets a gold star for catching this one. I wish I listened to her a little more closely when she pointed it out to me last week.

1) Clean Vista Install
2) Install 1.5.0.10.
3) Note that the 1.5.0.10 shim provided by Microsoft appears to be writing out the following Vista Keys:
 
Key: HKLM \ Software  \ RegisteredApplications 
Name: Mozilla Thunderbird
Value: Software\Clients\Mail\Mozilla Thunderbird\Capabilities

It also writes out the following Capabilities keys for Clients\Mail\Mozilla Thunderbird:

Startmenu 
URLAssociations
  mailto Mozilla Thunderbird.Url.mailto

This is particularly bad because Thunderbird 2 uses 'Thunderbird' not 'Mozilla Thunderbird' for the name of the key we write to RegisteredApplications. As a result the user will see Thunderbird listed twice in Default Programs.

Neither Rob nor I have any idea why the shim is generating these keys, it certainly doesn't for Firefox.
Flags: blocking-thunderbird2+
(Assignee)

Comment 1

12 years ago
The shim also writes out Classes\Mozilla Thunderbird.Url.mailto which we're going to need to delete.
Status: NEW → ASSIGNED
(Assignee)

Comment 2

12 years ago
these keys are bogus too:

Clients\Mail\Mozilla Thunderbird\Capabilities
   AppDescription Mozilla Thunderbird
   
Clients\Mail\Mozilla Thunderbird\DefaultIcon
   c:\Program Files\Mozilla Thunderbird\chrome\icons\default\messengerWindow.ico,0
(Assignee)

Comment 3

12 years ago
Created attachment 258070 [details] [diff] [review]
possible fix

FixClassKeys is called by both PostUpdate and the installer.

Remove the bogus Mozilla Thunderbird.Url.mailto protocol handler in Software\Classes.

Remove the bogus Mozilla Thunderbird entry in Software\RegisteredApplications.

The rest of the bogus keys already get updated by both the installer and PostUpdate in SetClientsMail which re-writes the values there.

Instead of piggy backing of FixClassKeys, I could also break this out into a separate method.
Attachment #258070 - Flags: review?(robert.bugzilla)
Attachment #258070 - Flags: review?(robert.bugzilla) → review+
(Assignee)

Comment 4

12 years ago
Fixed branch and trunk. Marcia, it would be helpful if you could test this again Monday morning.

To test:

1) Install Thunderbird 1.5.0.x
2) Verify that 'Mozilla Thunderbird' gets listed in your Default Programs list
3) Now Install Thunderbird 2, refresh the default programs list again. You should see that the "Mozilla Thunderbird" entry is no longer listed. you should see Thunderbird and Thunderbird (News)
Keywords: fixed1.8.1.3
(Assignee)

Updated

12 years ago
Duplicate of this bug: 372276
verified fixed using the Thunderbird 2 nightly, version 2.0pre (20070315).

I verified by doing the following:

1. On a clean Vista install with a clean profile, I installed Thunderbird 1.5.0.10.
2. Confirmed that "Mozilla Thunderbird" showed in the default program list. Then I uninstalled 1.5.0.10.
3. Installed the latest Thunderbird 2 nightly, version 2.0pre (20070315).
4. Confirmed that "Mozilla Thunderbird" was no longer listed in the default programs, and there were two entries for Thunderbird, Thunderbird and Thunderbird (News).


(In reply to comment #4)
> Fixed branch and trunk. Marcia, it would be helpful if you could test this
> again Monday morning.
> 
> To test:
> 
> 1) Install Thunderbird 1.5.0.x
> 2) Verify that 'Mozilla Thunderbird' gets listed in your Default Programs list
> 3) Now Install Thunderbird 2, refresh the default programs list again. You
> should see that the "Mozilla Thunderbird" entry is no longer listed. you should
> see Thunderbird and Thunderbird (News)
> 

Keywords: fixed1.8.1.3 → verified1.8.1.3
Resolving fixed since 1.5.0.x is now out-of-life and comment #6 says that it is verified fixed.
Status: ASSIGNED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.