MIME messages with improper "cid"s originating from Outlook 2003 do not display

RESOLVED INVALID

Status

RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: al, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.10) Gecko/20070216 Firefox/1.5.0.10
Build Identifier: 1.5.0.10 (20070221)

Outlook 2003 / Microsoft Exchange V6.5 can produce a MIME messages structure containing formatted text and embedded image(s) which result in TB showing a blank Message window and void "Message Source".  I suspect that the message was unparseable by TB.

I will attach a working and unworking email which have the same MIME structure:

Entity  Content-Type         Name         Encoding
1       multipart/alternative	 	 
1.1     text/plain                        quoted-printable
1.2	text/html                         quoted-printable
2	image/jpeg           image001.jpg base64
(etc more images)

In comparison I see that the working email defines pointers to images using the syntax: 
   src="cid:411484123@09032007-329C"
and an embedded image with
   Content-ID: <411484123@09032007-3295>

The failing email defines a pointer to an image using
   src="image001.jpg"          [no "cid:"]
and an embedded image with
   Content-ID: <image001.jpg@01C75BE1.7384A2F0>

Does the failing message fail because of improper MIME composition?

If so, could we create a means to parse it anyway since, like it or not, the Outlook beast is a very widely used email client?

I have compared these two message using Squirrel Mail's HTML message viewer.  It parses the MIME structure and renders the HTML (although fails to show the image inline, only makes them available as an attachment).  

There are three outcomes of how the faulty email could be displayed:

1. fail to show anything at all - (TB current behaviour)

2. show the HTML with broken placeholders and unassociated images as attachments (like Squirrelmail)

3. repair the broken format and display the images in-line as the author intended.

Reproducible: Sometimes

Steps to Reproduce:
I am not sure what actions cause Outlook to produce the broken message; I suspect it is where there has been a lot of forwarding of image content, rather than a pure first-time created email
(Reporter)

Comment 1

12 years ago
Broken Email demonstrating the fault: http://www.starfishzone.com/bugzilla/broken.txt
Working Email created with same client which works:
http://www.starfishzone.com/bugzilla/working.txt

Comment 2

12 years ago
Created attachment 258117 [details]
Corrected sample of broken message (zipped)

The .TXT files you have put up are clearly broken, because all the header indentation has been lost.  In particular, this causes an issue with
=======================
Content-Type: multipart/related;
 type="multipart/alternative";
 boundary="----_=_NextPart_001_01C762A4.E1B088B0"
=======================
without those leading spaces on the second two lines, the Content-Type header is not parsed correctly, the boundary information is lost, and nothing can be found, in either message.

Here's a .EML copy of the 'broken' message with the indentation fixed; it displays correctly for me.
(Reporter)

Comment 3

12 years ago
Thank you Mike; I foolishly grabbed the EML via a web interface and that is how the reformatting crept it. 

I have done more work on understanding what is causing the display to break.  The actual problem is quite different from what I original assumed it to be; it is actual a client caching issue.  Therefore I am closing this issue and have opened bug 373821.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.