Cycle collection topcrash [@ canonicalize]

RESOLVED DUPLICATE of bug 373219

Status

()

Core
XPCOM
--
critical
RESOLVED DUPLICATE of bug 373219
11 years ago
7 years ago

People

(Reporter: Jesse Ruderman, Unassigned)

Tracking

({crash, topcrash})

Trunk
x86
Mac OS X
crash, topcrash
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(crash signature)

(Reporter)

Description

11 years ago
According to Talkback, [@ canonicalize] became a very frequent crash on March 8.  It is the #1 Firefox trunk topcrash for the last 10 days despite only having a few incidents before the last 2 days.

At least three of them look like TB30109557, with some mentions of nsHTMLFormElement and nsPasswordManager:

canonicalize  [mozilla/xpcom/base/nscyclecollector.cpp, line 630]
GraphWalker::NoteXPCOMChild  [mozilla/xpcom/base/nscyclecollector.cpp, line 641]
ElementTraverser  [mozilla/content/html/content/src/nshtmlformelement.cpp, line 570]
nsBaseHashtable<nsCStringHashKey,nsAutoPtr<nsPasswordManager::SignonHashEntry>,nsPasswordManager::SignonHashEntry *>::EnumerateRead  [mozilla/dist/include/xpcom/nsbasehashtable.h, line 188]
nsHTMLFormElement::cycleCollection::Traverse  [mozilla/content/html/content/src/nshtmlformelement.cpp, line 578]

(That's the entire stack; I don't know why there's nothing below Traverse.)
Flags: blocking1.9?
(Reporter)

Comment 1

11 years ago
philor says he thinks this is a dup of bug 373219.
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 373219

Updated

11 years ago
Flags: blocking1.9?
(Assignee)

Updated

7 years ago
Crash Signature: [@ canonicalize]
You need to log in before you can comment on or make changes to this bug.